Closed Bug 666257 Opened 8 years ago Closed 8 years ago

Connect to Sync popup is not dismissed when device Back button is tapped in Awesome bar/Desktop Tab

Categories

(Firefox for Android Graveyard :: General, defect, P3)

Firefox 9
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: xti, Assigned: lucasr)

Details

Attachments

(4 files, 5 obsolete files)

Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/20110621
Firefox/7.0a1 Fennec/7.0a1
Device: Motorola Droid 2
OS: Android 2.2

Steps to reproduce:
1. Open Fennec app
2. Tap on URL Bar
3. Tap on Desktop Tab
4. Tap device Back button twice

Expected result:
After step 4, the opened Sync popup at step 3 is dismissed.

Actual result:
Connect to sync popup is not dismissed, no matter how many taps are performed at step 4.

Note:
Device should not be connected to Sync before performing the first step!
Priority: -- → P3
Taking.
Assignee: nobody → lucasr.at.mozilla
Attached patch Dismiss dialogs before panels (obsolete) — Splinter Review
Attachment #554100 - Flags: review?(mbrubeck)
Attachment #554101 - Flags: review?(mbrubeck)
Attached patch Remove redundant panel update (obsolete) — Splinter Review
Attachment #554102 - Flags: review?(mbrubeck)
Attachment #554100 - Flags: review?(mbrubeck) → review+
Comment on attachment 554101 [details] [diff] [review]
Open sync dialog after the panel for correct dialog stacking

Thanks for the good explanatory comments.
Attachment #554101 - Flags: review?(mbrubeck) → review+
Comment on attachment 554102 [details] [diff] [review]
Remove redundant panel update

Nice cleanup work!
Attachment #554102 - Flags: review?(mbrubeck) → review+
Comment on attachment 554100 [details] [diff] [review]
Dismiss dialogs before panels

I didn't spot the problem in my review, but in testing with this patch I noticed that when I tap in the urlbar, then switch from "All Pages" to any other panel, then pressing escape will no longer work to dismiss the awesomescreen.

Also, s/Escale/Escape/ in the commit message.
Attachment #554100 - Flags: review+ → review-
Matt, This patch is correct. The bug you found is actually caused by a bug in the activePanel setter which I fixed in the patch. I fixed the commit message.
Attachment #554100 - Attachment is obsolete: true
Attachment #554349 - Flags: review?(mbrubeck)
This patch should go before all other patches. It fixes dialog stack updates when setting active panels in BrowserUI.
Attachment #554350 - Flags: review?(mbrubeck)
Attachment #554350 - Flags: review?(mbrubeck) → review+
Attachment #554349 - Flags: review?(mbrubeck) → review+
Keywords: checkin-needed
Attachment #554349 - Attachment is obsolete: true
Attachment #554399 - Flags: review+
Updated all patches to include bug number and reviewer id.
Attachment #554102 - Attachment is obsolete: true
Attachment #554401 - Flags: review+
Mozilla/5.0 (Android; Linux armv7l; rv:9.0a1) Gecko/20110830 Firefox/9.0a1 Fennec/9.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.