Hitting "Stop" in venkman hangs the browser; closing the debugger window crashes the browser

RESOLVED DUPLICATE of bug 616899

Status

RESOLVED DUPLICATE of bug 616899
7 years ago
5 days ago

People

(Reporter: shill, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14

Hitting "Stop" in venkman hangs the browser; closing the debugger window crashes the browser

Reproducible: Always

Steps to Reproduce:
1. Start Seamonkey -- there is only one (empty) window
2. Start venkman (Tools - Web Dev - Javascript Debugger)
3. Hit the Stop button (red cross)
=> at this point, the debugger isn't painted anymore, all panes turn black, and the whole browser hangs (becomes unresponsive)
4. Close the debugger window
=> this crashes the browser
(Reporter)

Comment 2

7 years ago
I tried 3 more times. It crashed twice.

The third time, the debugger actually managed to stop (it took 2-3 seconds) and closing the window only produced a warning along the lines of "are you sure you want to quit while you are debugging?"

bp-fc22b706-fcfa-4a9a-bfdc-d02c72110622  22/06/2011  18:04
bp-e631c4c4-3f6a-43ea-8150-9b96c2110622  22/06/2011  18:01
(Reporter)

Comment 3

7 years ago
From the previous stack traces, here are the 3 different places where the crash occured. The first shows up in bug 583496

[@ nsTreeBodyFrame::PaintColumn(nsTreeColumn*, nsRect const&, nsPresContext*, nsIRenderingContext&, nsRect const&) ]

[@ nsTreeBodyFrame::PrefillPropertyArray(int, nsTreeColumn*) ]

[@ RuleProcessorData::RuleProcessorData(nsPresContext*, nsIContent*, nsRuleWalker*, nsCompatibility*) ]

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 616899
(Reporter)

Comment 5

3 years ago
I don't think this is a dupe, as this bug covers multiple crash signatures, only one of which is covered by bug 616899.

But it may not matter, I hear the JS debugger is deprecated?

Comment 6

3 years ago
correct, it is deprecated

Updated

5 days ago
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.