Last Comment Bug 666312 - Warning followed by assertion from reftest/tests/modules/libpr0n/test/crashtests/delaytest.html?523528-1.gif
: Warning followed by assertion from reftest/tests/modules/libpr0n/test/crashte...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: mozilla11
Assigned To: Matt Woodrow (:mattwoodrow)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 10:28 PDT by Bas Schouten (:bas.schouten)
Modified: 2012-02-01 14:00 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Check CairoStatus of surfaces in DrawImage (1.05 KB, patch)
2011-11-18 04:47 PST, Matt Woodrow (:mattwoodrow)
matt.woodrow: review+
Details | Diff | Splinter Review

Description Bas Schouten (:bas.schouten) 2011-06-22 10:28:18 PDT
This tests triggers the creation of a very large image surface. This fails because of checks, but the codepaths this triggers then continue to use the (invalid) image surface. This triggers a couple of assertions, but the NULL surface ends up being silently ignored by Cairo.

This doesn't seem like it's something we should rely on though, it seems to be a result of the 'RasterImage' believing it's ridiculously big (40K+).
Comment 1 Bas Schouten (:bas.schouten) 2011-06-22 10:32:27 PDT
The GIF actually seems to have a frame that big (49173x49173), so the fundamental problem seems to be more about how RasterImage deals with the fact it is not allowed to create a new image surface of that size.
Comment 2 Matt Woodrow (:mattwoodrow) 2011-11-18 04:47:48 PST
Created attachment 575423 [details] [diff] [review]
Check CairoStatus of surfaces in DrawImage
Comment 3 Ed Morley [:emorley] 2011-11-19 05:15:17 PST
https://hg.mozilla.org/mozilla-central/rev/6606fa72c881

Note You need to log in before you can comment on or make changes to this bug.