bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[RfE] Mozilla should have preference for switching off Flash support etc.

RESOLVED DUPLICATE of bug 19118

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 19118
18 years ago
14 years ago

People

(Reporter: Mark Slater, Assigned: Matthew Paul Thomas)

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT)
BuildID:    20010124

Mozilla should offer option to switch off flash, shockwave and other rich media 
support.

Reproducible: Always
Steps to Reproduce:
1. Goto news.com
2. Open any article
3. Swear demonically as your precious bandwidth is wasted on downloading those 
damn flash banners

After seeing flash being used ever more in more... "intrusive" ways *cough* 
banner ads *cough*, i think the option to switch off flash support (and other 
stuff, for that matter [beatnik, realplayer etc.]) would be really really cool. 
probably easier said than done, too =)

Will add screenshot of preferences.
(Reporter)

Comment 1

18 years ago
Created attachment 23531 [details]
Proposed look of preferences window

Comment 2

18 years ago
Confirming and over to Prefs.
Assignee: asa → matt
Status: UNCONFIRMED → NEW
Component: Browser-General → Preferences
Ever confirmed: true
OS: Windows NT → All
QA Contact: doronr → sairuh
Hardware: PC → All
Summary: Mozilla should have preference for switching off Flash support etc. → [RfE] Mozilla should have preference for switching off Flash support etc.

Comment 3

18 years ago
That would be realy nice.

Comment 4

18 years ago
I'd much prefer a plugin arbitrator. Something that allows you to disable 
plugins entirely, or change what mime types they handle.  Since it would be 
similar to helper applications, it should either go in that, or as 
Navigator\Plugins.

=>UIDF for comments.
Assignee: matt → hangas
Component: Preferences → User Interface: Design Feedback
Keywords: helpwanted
QA Contact: sairuh → mpt
(Assignee)

Comment 5

18 years ago
In the helper apps prefs for each MIME type, in addition to `Mozilla' `Ask me', 
`Save to Disk', `Foo application', and `Bar plugin', we could have `Ignore'.

Comment 6

18 years ago
note related bug 19118

Comment 7

18 years ago
I think, in addition to the global on/off switch for these plugins, you should 
be able to do it on a domain name basis as well. When you enter a domain to be 
blocked (or allowed), you specify which plugins out of the ones installed 
should be allowed/disallowed.

For example, right now I would just disable flash for go.com and 
news.com/cnet.com, because those are the only sites I visit where they are 
doing annoying flash ads.

Comment 8

18 years ago
Thomas Winzig <no_spam@winzig.com> please don't change the scope or focus of a 
bug report. We try to limit bugs to a single issue. I suspect what you want is 
already possible, please search bugzilla for site prefs bugs.

Comment 9

18 years ago
I'm sorry, I was trying to suggest the original feature request be usurped by 
my idea.

Comment 10

18 years ago
I think that when the window saying "You need a plugin to view Shockwave Flash,
press ok to download." that pops up when you don't have the plugin installed
should contain also "No, and never bother me with that again" besides the "OK
and "cancel" buttons

Comment 11

18 years ago
Seems like this bug is moving towards a plugin manager of sorts (kind of like
the cookie manager).

Comment 12

18 years ago
Would it be sufficient to be able to uninstall plug-ins you don't want, and be 
able to temporarily disable all plug-ins (or disable all plug-ins for a given 
site)?  I can't think of many situations where I'd want to allow Flash but not 
Java, for example.

Comment 13

18 years ago
Well, I think it should be treated like cookies and images - you can have sites
with allowed/disallowed cookies, with allowed and disallowed images, so you
should have also list for allowing/disallowing plugins form certain sites, or do
it like images - have option to disallow rich media (plugins) from different
domains.

Comment 14

18 years ago
if i'm testing fallback, i'd want to be able to individually disable plugins.

Comment 15

18 years ago
Chaning the qa contact on these bugs to me. MPT will be moving to the 
owner of this component shortly. I would like to thank him for all his hard 
work as he moves roles in mozilla.org...Yada, Yada, Yada...
QA Contact: mpt → zach

Comment 16

18 years ago
Created attachment 26684 [details]
Screenschot of H-J's Macromedia Flash Blocker

Comment 17

18 years ago
Can this be of any help??

Comment 18

18 years ago
Created attachment 26708 [details]
Screenshot of Flash Manager

Comment 19

18 years ago
Created attachment 26709 [details]
Screenshot when this pref("flashblocker.enabled", false); is set

Comment 20

18 years ago
Created attachment 26710 [details]
Screenshot from Image Manager when pref("flashblocker.enabled", false); (no tab!!)

Comment 21

18 years ago
BTW I'm working on an more powerfull version right now.

O Play Macromedia Flash files only once
O Use Macromedia Flash file settings
O Never play Macromedia Flash files

/H-J.

Comment 22

18 years ago
updating to new owner. sorry for the spam.
Assignee: hangas → mpt
*** Bug 86244 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 24

17 years ago
Bah.

*** This bug has been marked as a duplicate of 19118 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 25

17 years ago
So, now you have one bug less Matthew. That other bug is not assigned to you!
Also note that that other bug is about a Plugin manager and not about blocking
Flash!

Yeah yeah, I hear you. You would say:" But IF that Plugin manager is capable of
setting the Mime-Type to none then there will be NO Flash content rendered.
That's right, but IF you do not use Mozilla at all, it won't render anything!

Comment 26

17 years ago
Bug 19118 now covers
- being able to change what plugins what handle what mime types.
- adding something similar to the cookie manager that determines whether a page 
is allowed to load a plugin.

It seems to me like the first makes the most sense as global settings that few 
people ever tweak, and the second as per-site settings that most advanced users 
will look at.  Does it really make sense to combine them into one ui?  Would 
combining them force the mime type settings to be per-site?

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.