The default bug view has changed. See this FAQ.

Angry Birds game is broken on latest Aurora

RESOLVED FIXED

Status

()

Core
Canvas: 2D
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: Adil Allawi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [relies on cross-domain textures], URL)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a2) Gecko/20110622 Firefox/6.0a2
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a2) Gecko/20110622 Firefox/6.0a2

Angry Birds draws with black rectangles for main content on latest Aurora

Reproducible: Always

Steps to Reproduce:
1.Open URL
2.See black rectangles

Actual Results:  
black rectangles

Expected Results:  
Angry birds

The SD version is working.
tracking-firefox6: --- → ?
Happens on Mac using both latest trunk and Firefox 5 as well.

Updated

6 years ago
tracking-firefox6: ? → +
Not clear if this is FF6-specific, tracking in the interim since Cheng seems to think it works in 4, but not on nightlies
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regressionwindow-wanted

Comment 3

6 years ago
Definitely works in 4, even the HD version at least on Mac.
m-c regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9014863a7e2a&tochange=d799c168c98d

That's when we fixed the WebGL cross-domain image thing.
Blocks: 656277
Keywords: regressionwindow-wanted
And indeed, the page tries to load the following into GL textures:

http://r2045.project-slingshot-hr.appspot.com/fowl/images/Menu/loading_and_splash/Splash_Rovio_Logo.png
http://r2045.project-slingshot-hr.appspot.com/fowl/images/Menu/loading_and_splash/Splash_Loading.png
http://r2045.project-slingshot-hr.appspot.com/fowl/images/Menu/loading_and_splash/Splash_AB_Logo.jpg
http://r2045.project-slingshot-hr.appspot.com/fowl/images/BackgroundThemes/RED_FLOWERS_BG_1.png
http://r2045.project-slingshot-hr.appspot.com/fowl/images/BackgroundThemes/RED_FLOWERS_BG_2.png
http://r2045.project-slingshot-hr.appspot.com/fowl/images/BackgroundThemes/RED_FLOWERS_BG_3.png
http://r2045.project-slingshot-hr.appspot.com/fowl/images/BackgroundThemes/RED_FLOWERS_FG_1.png
http://r2045.project-slingshot-hr.appspot.com/fowl/images/BackgroundThemes/RED_FLOWERS_FG_2.png
http://r2045.project-slingshot-hr.appspot.com/fowl/sprite_sheets/INGAME_MENU_MAIN_MENU.png
****, they must have just changed it, it worked until a few days ago (I tested it after the change blocking cross domain textures).

Well at least, Chrome has the same restriction, though they have already implemented the CORS relaxation which means that soon enough their Angry Birds site will be updated to use CORS making it work at least in Chrome, and also in Firefox as soon as bug 662599 is fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 662599
We should track this separately.
Status: RESOLVED → REOPENED
Depends on: 662599
Resolution: DUPLICATE → ---
Summary: Canvas based game not displaying in latest Aurora → Angry Birds game is broken on latest Aurora

Comment 8

6 years ago
Windows 7 x64 
Firefox 8.0a1 
Confirmed
FWIW last time we checked it was also broken in chrome 14, which has the CORS-based mechanism in place for cross-domain textures. It's as if Angry Birds suddenly started using cross-domain textures without CORS.

Updated

6 years ago
Whiteboard: [relies on cross-domain textures?]
Working again here, definitely thanks to bug 664299.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: [relies on cross-domain textures?] → [relies on cross-domain textures]
Sorry, replied a bit too fast. Working again here, thanks to either Angry Birds no longer using cross-domain textures, or to a combination of Angry Birds using cross-domain textures with CORS and bug 664299.
Duplicate of this bug: 674153

Updated

6 years ago
tracking-firefox6: + → ---
You need to log in before you can comment on or make changes to this bug.