Last Comment Bug 666510 - the binary distribution of xulrunner 5.0 doesn't correctly work on mac os x
: the binary distribution of xulrunner 5.0 doesn't correctly work on mac os x
Status: RESOLVED FIXED
:
Product: Toolkit Graveyard
Classification: Graveyard
Component: XULRunner (show other bugs)
: unspecified
: x86_64 Mac OS X
: -- major (vote)
: mozilla6
Assigned To: Matthew Gertner
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-23 00:15 PDT by passfree
Modified: 2016-02-12 08:12 PST (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Move the code for OS X app bundles from GRE_GetGREPathWithProperties to stub (1.98 KB, patch)
2011-06-27 07:41 PDT, Matthew Gertner
benjamin: review+
asa: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description passfree 2011-06-23 00:15:22 PDT
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_7) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.797.0 Safari/535.1
Build Identifier: Xulrunner 5.0 binary distribution doesn't work

I just downloaded Xulrunner 5.0 and tried to run it the same way as  usual on Mac OS X. Unfortunately, I get the following problems:

* if xulrunner is launched within the app bundle MaOS folder the following error is generated: "Could not find the Mozilla runtime." The app 
bundle is structured correctly and it works fine under xulrunner 2.0. 

* if xulrunner-bin is launched with the path to the ini file, i.e. Frameworks/XUL.framework/xulrunner-bin --app Resources/ 
application.ini, the following error is generated: "Error: unrecognized application.ini path." This works fine under xulrunner 
2.0. 

Keep in mind that I am only swapping the Framework/XUL.framework sym link which used to point to xulrunner2.0 to xulrunner5.0. This sort of 
thing worked so far until and including the latest xulrunner 2.0.

Am I missing an important change or is the binary package broken? 

Reproducible: Always

Steps to Reproduce:
See above.

Actual Results:  
The app doesn't launch.

Expected Results:  
The app should launch.
Comment 1 Benjamin Smedberg [:bsmedberg] 2011-06-23 10:18:58 PDT
Matt, I think this is the one we talked about on IRC today.
Comment 2 Matthew Gertner 2011-06-27 07:41:37 PDT
Created attachment 542154 [details] [diff] [review]
Move the code for OS X app bundles from GRE_GetGREPathWithProperties to stub
Comment 3 Matthew Gertner 2011-06-27 07:43:15 PDT
I should mention that when I built 5.0, the dist/XUL.Framework directly didn't have very much in it (NSPR and other DLLs were missing). I'm not sure if this is another bug or by design. When I copied the whole dist/bin directory into XUL.Framework in my app bundle it worked fine.
Comment 4 Matthew Gertner 2011-06-28 05:51:51 PDT
What's the next step to get this landed?
Comment 5 Dão Gottwald [:dao] 2011-07-02 09:11:57 PDT
http://hg.mozilla.org/mozilla-central/rev/0c02168c83a6
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-07-16 19:18:45 PDT
Should we be landing this for 6?
Comment 7 Benjamin Smedberg [:bsmedberg] 2011-07-17 10:53:13 PDT
Comment on attachment 542154 [details] [diff] [review]
Move the code for OS X app bundles from GRE_GetGREPathWithProperties to stub

Yeah, we should take this on beta: it's not part of the Firefox build at all, but we do build XR builds from the branches and this is a bit embarrassing.
Comment 8 Asa Dotzler [:asa] 2011-07-17 21:26:36 PDT
Comment on attachment 542154 [details] [diff] [review]
Move the code for OS X app bundles from GRE_GetGREPathWithProperties to stub

(I'm lone-gunning this one as important and NPOTB. Hope other drivers are OK with that.)
Comment 9 Boris Zbarsky [:bz] (still a bit busy) 2011-07-18 12:03:41 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/65ed6316d72d

Note You need to log in before you can comment on or make changes to this bug.