Last Comment Bug 666569 - Remove the Intel Direct2D GPU blacklist
: Remove the Intel Direct2D GPU blacklist
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 590373
Blocks: 595364
  Show dependency treegraph
 
Reported: 2011-06-23 06:34 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2011-08-08 02:20 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove Intel D2D blacklist (2.08 KB, patch)
2011-06-23 06:34 PDT, Benoit Jacob [:bjacob] (mostly away)
joe: review+
bas: feedback+
asa: approval‑mozilla‑aurora-
Details | Diff | Splinter Review

Description Benoit Jacob [:bjacob] (mostly away) 2011-06-23 06:34:35 PDT
Created attachment 541359 [details] [diff] [review]
remove Intel D2D blacklist

In bug 595364 we decided to block Direct2D on some Intel GPUs. Later while fixing bug 590373 it appeared that that was most probably only a special case of a more general problem with mis-installed Intel drivers, and the patch in bug 590373 fixed that. Since then, it is very likely that the Direct2D blocklist in bug 595364 is useless. This patch removes it.
Comment 1 Bas Schouten (:bas.schouten) 2011-06-23 08:21:27 PDT
Comment on attachment 541359 [details] [diff] [review]
remove Intel D2D blacklist

Let's do this!
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2011-06-27 10:44:10 PDT
http://hg.mozilla.org/mozilla-central/rev/9aeebeda6b05
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2011-06-27 10:45:31 PDT
Comment on attachment 541359 [details] [diff] [review]
remove Intel D2D blacklist

Please give this aurora approval: this only needs Beta testing.
Comment 4 Asa Dotzler [:asa] 2011-06-28 14:59:48 PDT
Comment on attachment 541359 [details] [diff] [review]
remove Intel D2D blacklist

we think we can still get value by trunk and aurora testing that's valuable so we'd like to see this go through the normal uplift process.

Note You need to log in before you can comment on or make changes to this bug.