Closed Bug 666617 Opened 8 years ago Closed 7 years ago

netwerk/ - compiler warnings on mac

Categories

(Core :: Networking, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 745296

People

(Reporter: joey, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [build_warning])

/mozilla/sandbox/gml/netwerk/base/src/nsFileStreams.h:131: warning: 'virtual nsresult nsFileInputStream::Init(nsIFile*, PRInt32, PRInt32, PRInt32)' was hidden
/mozilla/sandbox/gml/netwerk/base/src/nsFileStreams.h:185: warning:   by 'virtual nsresult nsPartialFileInputStream::Init(nsIFile*, PRUint64, PRUint64, PRInt32, PRInt32, PRInt32)'
/mozilla/sandbox/gml/netwerk/base/src/nsFileStreams.h:133: warning: 'virtual PRBool nsFileInputStream::Read(const IPC::Message*, void**)' was hidden
/mozilla/sandbox/gml/netwerk/base/src/nsFileStreams.h:189: warning:   by 'virtual nsresult nsPartialFileInputStream::Read(char*, PRUint32, PRUint32*)'
/mozilla/sandbox/gml/netwerk/base/src/nsSocketTransport2.cpp:1492: warning: enumeral mismatch in conditional expression: 'nsISocketTransport::<anonymous enum>' vs 'nsISocketTransport::<anonymous enum>'
/mozilla/sandbox/gml/netwerk/wifi/osx_corewlan.mm:85: warning: no '+interface' method found
/mozilla/sandbox/gml/netwerk/wifi/osx_corewlan.mm:85: warning: (Messages without a matching method signature
/mozilla/sandbox/gml/netwerk/wifi/osx_corewlan.mm:85: warning: will be assumed to return 'id' and accept
/mozilla/sandbox/gml/netwerk/wifi/osx_corewlan.mm:85: warning: '...' as arguments.)
/mozilla/sandbox/gml/netwerk/wifi/osx_corewlan.mm:85: warning: no '-scanForNetworksWithParameters:error:' method found
/mozilla/sandbox/gml/netwerk/wifi/osx_corewlan.mm:105: warning: no '-bssidData' method found
/mozilla/sandbox/gml/netwerk/wifi/osx_corewlan.mm:111: warning: no '-bssid' method found
/mozilla/sandbox/gml/netwerk/wifi/osx_corewlan.mm:129: warning: no '-rssiValue' method found
/mozilla/sandbox/gml/netwerk/wifi/osx_corewlan.mm:131: warning: no '-rssi' method found
/mozilla/sandbox/gml/netwerk/wifi/osx_corewlan.mm:136: warning: no '-ssid' method found
/mozilla/sandbox/gml/netwerk/build/../base/src/nsFileStreams.h:133: warning: 'virtual PRBool nsFileInputStream::Read(const IPC::Message*, void**)' was hidden
/mozilla/sandbox/gml/netwerk/build/../base/src/nsFileStreams.h:189: warning:   by 'virtual nsresult nsPartialFileInputStream::Read(char*, PRUint32, PRUint32*)'
/mozilla/sandbox/gml/netwerk/build/../base/src/nsFileStreams.h:131: warning: 'virtual nsresult nsFileInputStream::Init(nsIFile*, PRInt32, PRInt32, PRInt32)' was hidden
/mozilla/sandbox/gml/netwerk/build/../base/src/nsFileStreams.h:185: warning:   by 'virtual nsresult nsPartialFileInputStream::Init(nsIFile*, PRUint64, PRUint64, PRInt32, PRInt
% uname -a
Darwin banshee.local 10.7.4 Darwin Kernel Version 10.7.4: Mon Apr 18 21:24:17 PDT 2011; root:xnu-1504.14.12~3/RELEASE_X86_64 x86_64
Whiteboard: [build_warnings]
Whiteboard: [build_warnings] → [build_warning]
We're getting rid of necko warnings in bug 745296
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 745296
You need to log in before you can comment on or make changes to this bug.