Last Comment Bug 666719 - Locationbar result list closes immadiatly when using trackpad or magic mouse
: Locationbar result list closes immadiatly when using trackpad or magic mouse
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Cocoa (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: mozilla9
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-23 13:00 PDT by Mehmet
Modified: 2011-09-06 14:02 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screencast (2.53 MB, application/octet-stream)
2011-06-27 12:45 PDT, Mehmet
no flags Details

Description Mehmet 2011-06-23 13:00:12 PDT
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0a1) Gecko/20110623 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0a1) Gecko/20110623 Firefox/7.0a1

OS: Mac OS 10.6.7
Nightly Build 7.0a1 (2011-06-23)

***please see the steps to reproduce***

Thanks
Mehmet

Reproducible: Always

Steps to Reproduce:
1. enable momentum scrolling under Mac OS or use the magic mouse
2. type something into the Locationbar so the the result list is to see
3. move the mousecursor over the result list
4. now make a trackpad or mouse swipe down and move immadiatly the cursor out of the result list

Actual Results:  
The Result list closes

Expected Results:  
It should not close

This also happens to select-field-menus :-(
Comment 1 Mehmet 2011-06-25 02:48:33 PDT
I have to correct me: This happens only with the magic mouse. The Trackpad is *NOT* affected.
Comment 2 Henrik Skupin (:whimboo) 2011-06-27 01:44:25 PDT
Mehmet, is that a regression for you? I can't reproduce it on my own box. Are you having add-ons installed?
Comment 3 Markus Stange [:mstange] 2011-06-27 10:45:41 PDT
Here's the call that closes popups on scroll events:
http://hg.mozilla.org/mozilla-central/annotate/cfd2af15e1c3/widget/src/cocoa/nsChildView.mm#l3936

We can add a check for momentum scroll there.

(In reply to comment #1)
> I have to correct me: This happens only with the magic mouse. The Trackpad
> is *NOT* affected.

The difference is that the trackpad stops sending momentum scroll events as soon as the mouse is moved a certain amount of pixels. The magic mouse doesn't.
Comment 4 Mehmet 2011-06-27 12:45:36 PDT
Created attachment 542235 [details]
Screencast

Hi. I think this is not a regression. It also happens in FF5. Not sure, but I think it was also an issue in FF4.

***Please see the enclosed screencast.***

Thanks and regards
Mehmet
Comment 5 Markus Stange [:mstange] 2011-08-12 06:18:07 PDT
The patch in bug 677279 fixes this.
Comment 6 Mounir Lamouri (:mounir) 2011-09-06 13:51:40 PDT
Markus, isn't it fixed now?
Comment 7 Markus Stange [:mstange] 2011-09-06 14:02:06 PDT
Oh, right.

Note You need to log in before you can comment on or make changes to this bug.