Closed Bug 667005 Opened 11 years ago Closed 11 years ago

hang when checking boxes in NetApp FilerView tool

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 646157

People

(Reporter: nmaul, Unassigned)

Details

Attachments

(2 files)

Attached file Sample broken page
When using the NetApp FilerView web tool, several pages have the ability to hang Firefox with 100% CPU usage for a very long time (30s to 6m30s, depending on the page). After that time, the page returns to normal. Checking another box, or unchecking the same box, results in the same hang again. The visual effect is that the checkbox darkens a shade, the browser hangs (beachballs), and then some time later it wakes up and the box finishes checking or unchecking (basically, the hang interrupts the animation, if that makes sense).

Confirmed on FF4 and FF5 released versions, and current Aurora, on OSX 10.6.7. Don't know about other platforms or versions. Safari 5.0.5 works normally, with no apparent delay at all.

Attached is the 'View Source' of one of the offending pages. This one hangs for approximately 6 minutes and 30 seconds on my Core i7 MacBook Pro. This page alone appears to be sufficient to cause the problem. That is, it should be enough to save it, open it in FF, and click a checkbox to generate the problem (the externals don't seem to be relevant).

Here is a 'Shark' profiling run while that page is beachballing: http://people.mozilla.org/~nmaul/firefox-netapp-hang.mshark.
Also hangs on Windows 7, Firefox 4.0.1. Tested by simply clicking on the attachment, and trying to check a box.
More complete list of known-hanging versions:

Firefox 4.0.1 Win7
Firefox 5 OSX 10.6.7
Firefox 4.0.? OX 10.6.7
Aurora 6.0a2 (2011-06-24) OSX 10.6.7
Nightly 7.0a1 (2011-06-24) OSX 10.6.7
Component: General → DOM
Product: Firefox → Core
QA Contact: general → general
If there's anyone in MV who'd like more info or see this happen, I'd be happy to demonstrate, I'm here for a while.
(In reply to comment #3)
> If there's anyone in MV who'd like more info or see this happen, I'd be
> happy to demonstrate, I'm here for a while.

Just to clarify, the reason I said that is because this is an internal mozilla IT access only website..since only IT has access to the NetApp filers.
It's reproducible with the test case.  It seems that we just spend a ton of time dispatching events ... the hang is temporary.
What kind of events?
Click events I think.  Example stack trace in a sec.
FWIW, I cannot reproduce this on Firefox 3.6.15 on Ubuntu 10.10 32-bit
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 646157
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.