Last Comment Bug 667012 - ensure that PKG_PATH exists when generating checksums file
: ensure that PKG_PATH exists when generating checksums file
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla6
Assigned To: John Ford [:jhford]
:
Mentors:
Depends on:
Blocks: 666953
  Show dependency treegraph
 
Reported: 2011-06-24 12:10 PDT by John Ford [:jhford]
Modified: 2011-09-22 15:32 PDT (History)
5 users (show)
khuey: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
ensure that PKG_PATH exists (462 bytes, patch)
2011-06-24 12:10 PDT, John Ford [:jhford]
khuey: review+
Details | Diff | Review
changeset (723 bytes, text/plain)
2011-06-24 14:41 PDT, John Ford [:jhford]
jhford: checkin+
Details
fix typo (500 bytes, patch)
2011-06-28 14:51 PDT, John Ford [:jhford]
khuey: review+
Details | Diff | Review
combined patch for branches (725 bytes, patch)
2011-06-29 08:54 PDT, John Ford [:jhford]
asa: approval‑mozilla‑beta+
Details | Diff | Review

Description John Ford [:jhford] 2011-06-24 12:10:53 PDT
Created attachment 541753 [details] [diff] [review]
ensure that PKG_PATH exists

When trying to upload the xulrunner sdks, there was a problem with the x86_64 sdk not being able to upload because the PKG_PATH directory didn't exist.  I am not sure why this directory didn't get created.

We could do mkdir -p $(DIST)/$(PKG_PATH) as the first step of the checksum: target, but I don't know if that is the desired course of action.
Comment 1 John Ford [:jhford] 2011-06-24 12:11:46 PDT
I did the gust of this in bug 666953 manually and everything worked.
Comment 2 John Ford [:jhford] 2011-06-24 12:31:31 PDT
(In reply to comment #1)
> I did the gust of this in bug 666953 manually and everything worked.

guts.

specifically bug 666953 comment 10
Comment 3 John Ford [:jhford] 2011-06-24 14:41:43 PDT
Created attachment 541807 [details]
changeset
Comment 4 John Ford [:jhford] 2011-06-24 15:03:40 PDT
Comment on attachment 541807 [details]
changeset

http://hg.mozilla.org/projects/build-system/rev/74f776d61679
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-06-25 18:39:57 PDT
http://hg.mozilla.org/mozilla-central/rev/74f776d61679
Comment 6 John Ford [:jhford] 2011-06-28 13:09:37 PDT
This needs to be merged into -aurora, -beta and -release to ensure that this doesn't bite us for releases off these trains.
Comment 7 John Ford [:jhford] 2011-06-28 14:50:07 PDT
There are missing parenthesis around the make variable.  As a result, instead of creating the PKG_PATH directory, we are creating a directory called "HECKSUM_FILE"
Comment 8 John Ford [:jhford] 2011-06-28 14:51:22 PDT
Created attachment 542612 [details] [diff] [review]
fix typo
Comment 9 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-06-29 08:36:30 PDT
Comment on attachment 542612 [details] [diff] [review]
fix typo

bah, should have caught that.
Comment 10 John Ford [:jhford] 2011-06-29 08:54:19 PDT
Created attachment 542830 [details] [diff] [review]
combined patch for branches

This is a combined patch intended for branch landing.
Comment 11 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-06-30 09:01:17 PDT
http://hg.mozilla.org/mozilla-central/rev/545d773cc96a
Comment 12 Chris AtLee [:catlee] 2011-07-06 05:23:56 PDT
Can we land this on mozilla-beta? It's breaking 6.0 beta xulrunner builds there, and will break 6.0 final as well.
Comment 13 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-07-06 19:53:52 PDT
Comment on attachment 542830 [details] [diff] [review]
combined patch for branches

Yeah ... not sure why this wasn't nommed.
Comment 14 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2011-07-12 13:08:00 PDT
(In reply to comment #13)
> Comment on attachment 542830 [details] [diff] [review] [review]
> combined patch for branches
> 
> Yeah ... not sure why this wasn't nommed.

I see this nom'd for beta. Should this also be nom'd for aurora?
Comment 15 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-07-12 13:11:10 PDT
This is in Aurora, because it made the cutoff.
Comment 16 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-07-12 14:51:31 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/2147a77f9e45
Comment 17 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-09-22 15:32:29 PDT
qa- as no QA fix verification needed

Note You need to log in before you can comment on or make changes to this bug.