JSWatchPointHandler claims to take a void *, but actually takes a JSObject *

RESOLVED DUPLICATE of bug 638054

Status

()

RESOLVED DUPLICATE of bug 638054
7 years ago
11 months ago

People

(Reporter: jimb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
The JSWatchPointHandler typedef, used by JS_SetWatchPoint and related functions, is a pointer to a function whose last argument, 'closure', is a 'void *'. However, the actual closure passed to JS_SetWatchPoint is a JSObject *, and the garbage collector treats it as such when it traces a watchpoint list.

The JSWatchPointHander's last argument should be changed to a 'JSObject *', to match its actual usage.
(Assignee)

Updated

4 years ago
Assignee: general → nobody

Comment 1

11 months ago
watch() was removed in bug 638054.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 638054
You need to log in before you can comment on or make changes to this bug.