Closed Bug 667160 Opened 11 years ago Closed 11 years ago

Restore Previous Session fails

Categories

(SeaMonkey :: Session Restore, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 665276

People

(Reporter: hhofer42, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 SeaMonkey/2.4a1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 SeaMonkey/2.4a1

When using "Restore Previous Session", the restored tabs and windows are empty and an error is logged:

Error: uncaught exception: [Exception... "'Failure' when calling method: [nsISessionStore::restoreLastSession]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://navigator/content/navigator.js :: restoreLastSession :: line 1504"  data: no]

Reproducible: Always

Steps to Reproduce:
1. Open one or more tabs
2. Close the SeaMonkey
3. Re-start SeaMonkey and select Go -> Restore Previous Session
I have a patch for Bug 665276 which seems to fix the issue. Setting dependency for the time being.
Depends on: 665276
(In reply to comment #1)
> I have a patch for Bug 665276 which seems to fix the issue.

Works like a charm (with a patched omni.jar).
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 665276
You need to log in before you can comment on or make changes to this bug.