Last Comment Bug 667225 - Latest TinderBox (Azure Build) crashes upon opening Psychedelic Browsing (IE Test Drive Experiment)
: Latest TinderBox (Azure Build) crashes upon opening Psychedelic Browsing (IE ...
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: P1 critical with 1 vote (vote)
: mozilla7
Assigned To: Bas Schouten (:bas.schouten)
:
: Milan Sreckovic [:milan]
Mentors:
ie.microsoft.com/testdrive/performanc...
: 667443 667673 (view as bug list)
Depends on:
Blocks: 651858
  Show dependency treegraph
 
Reported: 2011-06-25 12:39 PDT by Girish Sharma [:Optimizer]
Modified: 2015-10-16 11:47 PDT (History)
15 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
_invalid_parameter_noinfo
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Silently ignore drawing glyph runs where no glyphs are to be drawn (1.31 KB, patch)
2011-06-25 23:10 PDT, Bas Schouten (:bas.schouten)
no flags Details | Diff | Splinter Review
Silently ignore drawing glyph runs where no glyphs are to be drawn v2 (1.31 KB, patch)
2011-06-25 23:16 PDT, Bas Schouten (:bas.schouten)
jmuizelaar: review+
Details | Diff | Splinter Review
Add a testcase for the bug (1.04 KB, patch)
2011-06-26 10:54 PDT, Bas Schouten (:bas.schouten)
jmuizelaar: review+
Details | Diff | Splinter Review

Description Girish Sharma [:Optimizer] 2011-06-25 12:39:56 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110625 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110625 Firefox/7.0a1

The latest hourly azure builds are having problem with specifically this IE test : Psychedelic Browsing ( http://ie.microsoft.com/testdrive/performance/psychedelicbrowsing/Default.html )

Reproducible: Always

Steps to Reproduce:
1.Have the latest Hourly (at point of bug posting) having the Azure Rendering engine ( http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1309018896/ )
2.Open link ie.microsoft.com/testdrive/performance/psychedelicbrowsing/Default.html
3.Start the Psychedelic Browsing test by clicking Find Out


Actual Results:  
Firefox Crashes

Expected Results:  
The test should run properly as it runs on latest Nightly (7.0a1 (2011-06-25))
Comment 1 Alice0775 White 2011-06-25 12:46:32 PDT
Crash on mozilla-inbound nightly:
Crash Report [@ _invalid_parameter_noinfo ]

Crash Id
bp-a88dc130-2960-4259-9658-5a09e2110625
bp-be57e6f6-dccc-4c20-9b0c-eb6f42110625
Comment 2 Joe Drew (not getting mail) 2011-06-25 13:21:04 PDT
If Alice sees it, this is confirmed. :)
Comment 3 Josh Tumath 2011-06-25 13:49:10 PDT
Could you add this a dependency of bug 651858?
Comment 4 Yakove 2011-06-25 20:37:30 PDT
Confirmed on latest m-c hourly build

https://crash-stats.mozilla.com/report/index/bp-d8ccec74-293d-45c6-9ed0-24f5b2110625
Comment 5 Bas Schouten (:bas.schouten) 2011-06-25 23:10:33 PDT
Created attachment 541992 [details] [diff] [review]
Silently ignore drawing glyph runs where no glyphs are to be drawn

This demo draws fill text call where the textrun reports no glyphs to be drawn. In this situation we should ignore the draw call and go on drawing rather than invalidly use the vector and cause a crash. The exact cause as to why the textrun reports no glyphs to be drawn should be examined further.
Comment 6 Bas Schouten (:bas.schouten) 2011-06-25 23:16:33 PDT
Created attachment 541993 [details] [diff] [review]
Silently ignore drawing glyph runs where no glyphs are to be drawn v2

I was unable to create this situation but we probably should just continue to draw any runs in the textrun that -do- draw valid glyphs. I've adjusted the patch for this.
Comment 7 Bas Schouten (:bas.schouten) 2011-06-25 23:29:12 PDT
Just to be clear, the same situation exists in traditional glyph drawing but it's silently ignored there as well, at gfxFont.cpp:1185. glyphCount there is found to be 0 similarly as for Azure canvas.
Comment 8 Girish Sharma [:Optimizer] 2011-06-26 03:39:57 PDT
Please push this to inbound as early as possible.
There might be several other places where a similar crash can occur once today's Nightly is out
Comment 9 Bas Schouten (:bas.schouten) 2011-06-26 08:36:13 PDT
This is pending review, once reviewed it will be pushed. I'm not sure what causes the condition, once we've figured out we should probably add a test for it. Until then I doubt this is a common situation but I'll keep an eye out.
Comment 10 Jeff Muizelaar [:jrmuizel] 2011-06-26 10:33:49 PDT
Comment on attachment 541993 [details] [diff] [review]
Silently ignore drawing glyph runs where no glyphs are to be drawn v2

Make sure you add a test case before pushing this.
Comment 11 Bas Schouten (:bas.schouten) 2011-06-26 10:54:24 PDT
Created attachment 542033 [details] [diff] [review]
Add a testcase for the bug

This adds a crashtest for this bug, it seems to occur when trying to draw 0-sized fonts.
Comment 12 Jeff Muizelaar [:jrmuizel] 2011-06-26 10:57:33 PDT
Comment on attachment 542033 [details] [diff] [review]
Add a testcase for the bug

Drop the xmlns stuff and give the test a better name like 0px-size-font-667225.html
Comment 15 Girish Sharma [:Optimizer] 2011-06-27 08:12:24 PDT
Did It miss today's Nightly ? I am not seeing it under the Nightly Changeset
http://hg.mozilla.org/mozilla-central/rev/5e072732cb45
Comment 16 Bas Schouten (:bas.schouten) 2011-06-27 08:14:15 PDT
It did miss today's nightly.
Comment 17 Bas Schouten (:bas.schouten) 2011-06-27 16:52:07 PDT
*** Bug 667673 has been marked as a duplicate of this bug. ***
Comment 18 David Baron :dbaron: ⌚️UTC-10 2011-06-28 11:46:09 PDT
*** Bug 667443 has been marked as a duplicate of this bug. ***
Comment 19 AndreiD[QA] 2011-07-07 06:33:15 PDT
The issue is not reproducible anymore. Verified fixed on:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a2) Gecko/20110706 Firefox/7.0a2
Mozilla/5.0 (X11; Linux i686; rv:7.0a2) Gecko/20110706 Firefox/7.0a2
Mozilla/5.0 (Windows NT 6.1; rv:7.0a2) Gecko/20110706 Firefox/7.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0a2) Gecko/20110706 Firefox/7.0a2

Note You need to log in before you can comment on or make changes to this bug.