Last Comment Bug 667286 - cairo.h should be included as "cairo.h" instead of "cairo/cairo.h"
: cairo.h should be included as "cairo.h" instead of "cairo/cairo.h"
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Takanori MATSUURA
:
Mentors:
: 667282 667423 (view as bug list)
Depends on:
Blocks: 651858
  Show dependency treegraph
 
Reported: 2011-06-26 07:21 PDT by Takanori MATSUURA
Modified: 2011-07-07 07:22 PDT (History)
5 users (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Include cairo.h as "cairo.h" instead of "cairo/cairo.h" (2.33 KB, patch)
2011-06-26 07:25 PDT, Takanori MATSUURA
bas: review+
Details | Diff | Review

Description Takanori MATSUURA 2011-06-26 07:21:54 PDT
After fixing bug 651858, the build failed with system cairo.

Some new files in gfx/2d include cairo.h as "cairo/cairo.h"
We should include cairo.h as "cairo.h" and add $MOZ_CAIRO_CFLAGS into gfx/2d/Makefile.in. It's the same manner as the other files which include cairo.h.
Comment 1 Takanori MATSUURA 2011-06-26 07:25:40 PDT
Created attachment 542017 [details] [diff] [review]
Include cairo.h as "cairo.h" instead of "cairo/cairo.h"
Comment 2 ojab 2011-06-26 08:27:11 PDT
*** Bug 667282 has been marked as a duplicate of this bug. ***
Comment 3 Bas Schouten (:bas.schouten) 2011-06-26 08:28:31 PDT
Comment on attachment 542017 [details] [diff] [review]
Include cairo.h as "cairo.h" instead of "cairo/cairo.h"

Review of attachment 542017 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 5 Mounir Lamouri (:mounir) 2011-06-27 02:15:22 PDT
Merged:
http://hg.mozilla.org/mozilla-central/rev/c957d129308b
Comment 6 Mounir Lamouri (:mounir) 2011-06-27 04:42:12 PDT
*** Bug 667423 has been marked as a duplicate of this bug. ***
Comment 7 AndreiD[QA] 2011-07-07 07:22:39 PDT
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a2) Gecko/20110706 Firefox/7.0a2
Verified fixed - detailed by the changeset in comment 5

Note You need to log in before you can comment on or make changes to this bug.