Last Comment Bug 667298 - Taskbar Tab preview in Windows 7's (Aero enabled) do not show up in latest Nightlies
: Taskbar Tab preview in Windows 7's (Aero enabled) do not show up in latest Ni...
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Windows 7
: -- major (vote)
: mozilla7
Assigned To: Bas Schouten (:bas.schouten)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-26 08:44 PDT by Girish Sharma [:Optimizer]
Modified: 2011-10-09 18:39 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Allow Taskbar Previews to explicitly create a thebes canvas (7.38 KB, patch)
2011-06-28 08:54 PDT, Bas Schouten (:bas.schouten)
roc: review+
roc: feedback+
Details | Diff | Splinter Review

Description Girish Sharma [:Optimizer] 2011-06-26 08:44:31 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110626 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110626 Firefox/7.0a1

Since the Azure build Nightly, The Tab preview have stopped working. I only get spinning wheel (with grey background) in the rectangle area meant for tab preview.

Reproducible: Always

Steps to Reproduce:
1.Have Windows 7 aero enabled and latest Nightly
2.Hover over Nightly icon in Taskbar till you get tab preview displayed


Actual Results:  
N preview is shown in any individual tab area

Expected Results:  
Either current tab's preview or all the tab's preview should be visible (depending on the usr;s settings)
Comment 1 Bas Schouten (:bas.schouten) 2011-06-26 08:52:25 PDT
Tab previews are not enabled by default are they?
Comment 2 Girish Sharma [:Optimizer] 2011-06-26 08:53:50 PDT
No . 
Edit : This is only reproducible when we have the setting "Show tab preview in windows taskbar" switched on
Comment 3 Alice0775 White 2011-06-26 12:13:33 PDT
Confirmed under condition of browser.taskbar.previews.enable = true,

Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/450e4d9ea2d5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 ID:20110625025936
Fails:
http://hg.mozilla.org/mozilla-central/rev/48ad4ffc4230
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110625 Firefox/7.0a1 ID:20110625030821
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=450e4d9ea2d5&tochange=48ad4ffc4230


Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c65f1fb0449d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 ID:20110624094307
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/46c3d095bc75
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 ID:20110624104626
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c65f1fb0449d&tochange=46c3d095bc75
Suspected bug: Bug 651858
Comment 4 WildcatRay 2011-06-28 05:51:27 PDT
FYI: When I disabled the pref gfx.canvas.azure.enabled, my taskbar tab previews displayed as expected.

Also, the pref browser.taskbar.previews.enable is disabled by default (I have enabled it), though, my experience has been only on very rare occasions that tabs previews do not display as expected. Restarting the browser corrects it.

Please let me know what, if any, additional information may be needed for triaging this. Thanks.
Comment 5 Girish Sharma [:Optimizer] 2011-06-28 06:32:38 PDT
Please someone confirm this bug and change its status from unconfirmend to something else like addigned ?
Comment 6 Bas Schouten (:bas.schouten) 2011-06-28 08:54:28 PDT
Created attachment 542488 [details] [diff] [review]
Allow Taskbar Previews to explicitly create a thebes canvas

This is a shot at a patch for this. The problem is InitializeWithSurface doesn't work on an Azure canvas. I added a CID for a thebes canvas specifically so taskbar previews can use that.
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-28 15:13:12 PDT
Comment on attachment 542488 [details] [diff] [review]
Allow Taskbar Previews to explicitly create a thebes canvas

Review of attachment 542488 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine, but how are we going to solve this long term? Can we implement InitWithSurface?
Comment 8 Bas Schouten (:bas.schouten) 2011-06-28 17:10:17 PDT
(In reply to comment #7)
> Comment on attachment 542488 [details] [diff] [review] [review]
> Allow Taskbar Previews to explicitly create a thebes canvas
> 
> Review of attachment 542488 [details] [diff] [review] [review]:
> -----------------------------------------------------------------
> 
> This looks fine, but how are we going to solve this long term? Can we
> implement InitWithSurface?

Once we have a cairo Azure backend, I'd say yes. Right now, no, there's simply no way to know how we can draw to whatever is passed in (if it's not a D2D surface) without doing a load of copying, readback and copying back. (i.e., create D2D Azure, draw to it, do a CreateSurfaceFromDrawTarget, and then draw back to the surface in this case, where it's a windows surface). Since we really need to draw to a windows surface for the taskbar previews this seems like the best solution for now.
Comment 9 Bas Schouten (:bas.schouten) 2011-06-28 17:10:42 PDT
Comment on attachment 542488 [details] [diff] [review]
Allow Taskbar Previews to explicitly create a thebes canvas

Requesting review then.
Comment 10 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-28 17:37:33 PDT
Comment on attachment 542488 [details] [diff] [review]
Allow Taskbar Previews to explicitly create a thebes canvas

Review of attachment 542488 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 11 Bas Schouten (:bas.schouten) 2011-06-29 18:03:42 PDT
Landed on mozilla-inbound:

http://hg.mozilla.org/integration/mozilla-inbound/rev/4eb4d1b81e9b
Comment 12 :Ms2ger (⌚ UTC+1/+2) 2011-06-30 04:46:08 PDT
This makes us support canvas.getContext("2dthebes") for content scripts. That's not acceptable.
Comment 13 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-30 04:53:02 PDT
We could call it moz-thebes and register it on the wiki page.

Or we could just reject it inside ::GetContext().
Comment 14 Marco Bonardo [::mak] 2011-06-30 06:11:20 PDT
http://hg.mozilla.org/mozilla-central/rev/4eb4d1b81e9b
Comment 15 WildcatRay 2011-07-01 06:35:27 PDT
I am seeing the tab previews as expected.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110701 Firefox/7.0a1 ID:20110701030757

C-set: beceddeee3f4

Thanks.
Comment 16 :Ms2ger (⌚ UTC+1/+2) 2011-07-05 03:38:31 PDT
Landed
http://hg.mozilla.org/mozilla-central/rev/a0b12f9bb58d
to address my comments in time for Firefox 7, with pending-r=roc based on your comments.
Comment 17 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-07-05 17:36:30 PDT
That looks great, thanks.
Comment 18 Mihaela Velimiroviciu (:mihaelav) 2011-09-08 05:00:43 PDT
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0

Unable to reproduce on latest 7(beta 4) build. Taskbar preview is displayed correctly.
Comment 19 Girish Sharma [:Optimizer] 2011-09-08 05:02:45 PDT
Isn't this bug Resolved Fixed ?
Please do not comment more.
Comment 20 Mihaela Velimiroviciu (:mihaelav) 2011-09-08 06:29:58 PDT
Changing status to VERIFIED-FIXED

Note You need to log in before you can comment on or make changes to this bug.