If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

missing glyphs when displaying GBK characters with GB2312 font

VERIFIED DUPLICATE of bug 71197

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 71197
17 years ago
17 years ago

People

(Reporter: kill this account, Assigned: Frank Tang)

Tracking

Trunk
mozilla0.9
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When a GB2312 font is used to display a GBK page some of the glyphs are blank.

We believe that GB2312 is missing these characters so it will never try to 
display those characters (thus no blank glyphs).

However when a GBK page is displayed with a GB2312 font the font switching 
system should note that GB2312 is missing those characters and get glyphs from 
another font (most likely a GBK font).

We suspect that the fill_info for GB2312 needs to zero out the non-existant 
characters/glyphs and then the font substitution system will work.
(Reporter)

Comment 1

17 years ago
Created attachment 23594 [details]
image showing missing glypsh (ignore the '?')
(Reporter)

Comment 2

17 years ago
Katakai-san,

will this bug be a show-stopper?
Status: NEW → ASSIGNED

Comment 3

17 years ago
Changed QA contact to ylong@netscape.com.
QA Contact: teruko → ylong
(Reporter)

Updated

17 years ago
Target Milestone: --- → mozilla0.8
(Assignee)

Comment 4

17 years ago
bstell. I don't understand this bug. GBK is a super set of GB2312. If the user do 
not have GBK font, it definitely won't display those characters which only 
encoded in GBK. 
I will mark this bug invalid. 
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
Mark as Verified according the comments of Frank Tang.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

17 years ago
Frank,

The issue here is that if a user selects a gb2312 font for gbk 
our code should fill in the missing glyphs from other fonts 
not leave them blank.

The reason we don't do this is that the gb2312 glyph info indicated
glyphs that are not the. Thus we don't do the fill in.


Status: VERIFIED → REOPENED
Resolution: INVALID → ---
(Reporter)

Updated

17 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 7

17 years ago
I see. Move this to moz0.9
Target Milestone: mozilla0.8 → mozilla0.9
(Assignee)

Comment 8

17 years ago
We need to clean up intl/uconv/ucvcn. The code there is very messy.

Updated

17 years ago
Blocks: 60916

Comment 9

17 years ago
Actually I'm also seeing this problem, but I'm not sure it's showstopper so
I need to ask to our Asian folks again about this problem.

The problem is that gbk-0 fonts are installed only in zh.GBK locales
on Solaris, which means when we set to use gtk-0 fonts for zh-CN for
workaround, user can not access the fonts in other than zh.GBK locales.
zh_CN.EUC locale provides gb2312 fonts but does not provide gbk-0 fonts,
vice versa, zh.GBK locale provides both gb2312 and gtk-0 fonts.

So I think we have to set gb2312 fonts for zh-CN langGroup on Solaris,
which means we can not take workaround that setting to gbk-0 fonts.

The additional workaround will be needed for Solaris, which is
when user wants to see GBK characters, users have to set gbk-0 fonts
in font setting and use zh.GBK locale on Solaris.

Brian and Frank,

Do you think you will be able to fix this by Netscape 6.5? (=Mozilla 1.0??)

Anyway, I'll talk to our L10N folks.

Comment 10

17 years ago
Hi,

I understand gb2312 is not enough to display whole glyphs of GBK, right?
If so, there is no way to display the glyphs properly at the environment
where gbk-0 fonts are not usable such as Solaris zh_CN.EUC locale.

When both gb2312 and gbk-0 fonts are available, it seems that fallback works
and picks up glyphs from gbk-0 fonts, but there are still some missing glyphs,
which are displayed as blank. That's problem, I think.

Can bug 69139 fix the problem?

(Reporter)

Comment 11

17 years ago
it looks to me that when the gb2312 reports it does not have
the glyph the font system starts searching thru all available
fonts for a readable glyph. The JIS fonts report they have some
of the glyphs. It appears that the JIS fonts indicate more
glyphs than they actually have.
(Reporter)

Comment 12

17 years ago
when I disable the FillInfo code on the Jis converters the blanks turn into 
question marks.
(Reporter)

Comment 13

17 years ago
this bug had two components for which I opened two separate bugs:

  Jis 208 may cause blank glyphs (FillInfo includes CP932)
  http://bugzilla.mozilla.org/show_bug.cgi?id=71197

  Solaris XListFonts reports invalid (no glyph) fonts
  http://bugzilla.mozilla.org/show_bug.cgi?id=71199

marking this bug as a dup

*** This bug has been marked as a duplicate of 71197 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 14

17 years ago
Verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.