Last Comment Bug 667632 - Consistency bug: link mouseover works for all browsers except for Firefox 5
: Consistency bug: link mouseover works for all browsers except for Firefox 5
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 5 Branch
: All Other
: -- normal (vote)
: Firefox 7
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 666604
Blocks: 583514
  Show dependency treegraph
 
Reported: 2011-06-27 15:11 PDT by yyz_junk
Modified: 2011-07-07 07:22 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description yyz_junk 2011-06-27 15:11:54 PDT
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18 GTB7.1
Build ID: 20110614230723

Steps to reproduce:

1.  Go to a site created with eSite Builder (many fulfilled by AT&T and SuperPages)
ex.1  http://blueeagleroofing.onyellowpages.com
ex.2  http://bw3pg.onyellowpages.com
2.  click on one of the navigation buttons located at top (the link shows correctly)


Actual results:

Nothing, the page does not load.


Expected results:

When clicking on the navigation button, it should load 
(as it does with previous versions of FF and other popular browsers).

Notes:  
-  This happens only in Firefox 5.
-  I've tried the page on FF3.6, FF4, IE8, IE9, Safari 5 and Chrome12, and the links work as expected.
-  While troubleshooting, I restarted in safe mode with all add-ons disabled and set my preferences back to default.  This did not correct the problem. 
-  After a lot of trial and error, it comes down to this line at the bottom of the page that's causing problems 
<a id="TGLink" style="display:none;" href="#">lnk</a>
While looking through the javascript, I found various functions using TGLink. I think something in Firefox 5 is not interpreting the javascript associated with links using TG_doLink (what's used in mouseovers) the same way as other browsers do.
Comment 1 Tim (fmdeveloper) 2011-06-27 17:03:59 PDT
Any errors in the error console?
Comment 2 (mostly gone) XtC4UaLL [:xtc4uall] 2011-06-27 17:13:11 PDT
Last good nightly: 2011-04-11 First bad nightly: 2011-04-12

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=09b605eb3e0d&tochange=a174b86200d6

BZ, is this similar/related to Bug 666985/Bug 666604?
Comment 3 Boris Zbarsky [:bz] 2011-06-27 20:40:45 PDT
Sure looks like it could be.  Fixing bug 666604 fixes this problem for me.
Comment 4 Boris Zbarsky [:bz] 2011-07-01 08:38:47 PDT
Fixed by changes in bug 666604.
Comment 5 Vlad [QA] 2011-07-07 07:22:28 PDT
Setting resolution to Verified Fixed on Mozilla/5.0 (Windows NT 6.1; rv:7.0a2) Gecko/20110706 Firefox/7.0a2

Note You need to log in before you can comment on or make changes to this bug.