Implement keyboard shortcut hold threshold timer for Quit (CMD/Ctrl + Q)

RESOLVED DUPLICATE of bug 565567

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 565567
7 years ago
2 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-chrome])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
As far as I'm aware, currently Chromium v14 [1] implements a very useful minimal feature that ultimately places a press duration threshold on the shortcuts for Quitting the browser: Command/Ctrl-Q. 

This ultimately acts as a preventative measure for accidentally closing the window when using keyboard shortcuts, such as the case for incidentally hitting Q when one meant to hit W (Close Window).

The method at which this is detailed to the end-user is via a visible toaster alert that simply indicates: "Hold ⌘Q to Quit", or Hold Control+Q to Quit".

I would love to see this minimal feature added to the Firefox product in the future. 

Currently testing this on Chromium 14.0.805.0 (90675)
(Reporter)

Comment 1

7 years ago
Created attachment 542477 [details]
Toaster notification - Chromium 14.0.805.0 (90675)
If this happens, *please* hook it to a pref. This would drive me absolutely crazy.

Comment 4

7 years ago
Isn't there a risk that pressing and holding Ctrl+Q will kill other programs as well if the computer is fast and the user is slow?

Comment 5

7 years ago
There exists a similar implementation request:
https://bugzilla.mozilla.org/show_bug.cgi?id=677702

Updated

7 years ago
URL: jjj

Comment 6

2 years ago
This is more or less a duplicate of bug 565567. And a WIP patch for this was worked on in bug 550559. There are too many bugs about this issue :)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565567
You need to log in before you can comment on or make changes to this bug.