Last Comment Bug 667962 - jemalloc in 2010 doesn't work on gmake
: jemalloc in 2010 doesn't work on gmake
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: neil@parkwaycc.co.uk
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-28 11:19 PDT by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2011-11-29 02:58 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Possible patch (1.89 KB, patch)
2011-07-23 16:38 PDT, neil@parkwaycc.co.uk
khuey: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-06-28 11:19:39 PDT

    
Comment 1 neil@parkwaycc.co.uk 2011-07-23 16:38:46 PDT
Created attachment 547970 [details] [diff] [review]
Possible patch

My mozillabuild gmake doesn't seem to mind this Makefile, but the double-colon rules force it to rebuild everything each time, which doesn't help. I stopped libs from depending on $(DIST)/lib because we don't do that anywhere else.
Comment 2 neil@parkwaycc.co.uk 2011-07-27 13:03:08 PDT
Pushed changeset 370bcc140023 to mozilla-central.
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2011-07-27 14:27:27 PDT
Backed out:

http://hg.mozilla.org/mozilla-central/rev/a627b24e684e
Comment 4 Mike Pesce (:By-Tor) 2011-07-28 08:24:06 PDT
Changeset http://hg.mozilla.org/mozilla-central/rev/4df55cccaff4 still crashes under vs2010.
Comment 5 neil@parkwaycc.co.uk 2011-07-28 09:27:01 PDT
Which make are you using? It works for me with 3.81.90
Comment 6 Mike Pesce (:By-Tor) 2011-07-28 09:29:33 PDT
(In reply to comment #5)
> Which make are you using? It works for me with 3.81.90

Using pymake this time.
Comment 7 Mike Pesce (:By-Tor) 2011-07-30 18:54:21 PDT
I hadn't had a chance to retry this patch with gmake until now.  It still crashes at the same point:

Generate a DSA key pair ...
Library File: d:/build/mozilla-central/objdir-ff-release/dist/lib/softokn3.dll 1
44384 bytes
Check File: d:/build/mozilla-central/objdir-ff-release/dist/lib/softokn3.chk
  hash: 20 bytes
    30 d7 c1 39 d9 19 a6 0e 6f 0f
    07 37 c7 b1 03 a1 4f a1 c9 04
  signature: 40 bytes
    bc 61 0c 00 44 6e cf ac f5 6d
    27 30 1c 1b be 43 04 b2 d1 ce
    5e 36 61 99 ce 92 91 b1 f6 30
    8c 1d b1 af d3 7b 38 3e e6 35
make[6]: *** [d:/build/mozilla-central/objdir-ff-release/dist/lib/softokn3.chk]
Error 5
make[6]: Leaving directory `/d/build/mozilla-central/security/nss/cmd/shlibsign'

make[5]: *** [libs] Error 2
Comment 8 ABE Hiroki (:hATrayflood) 2011-07-30 23:01:44 PDT
maybe https://bugzilla.mozilla.org/show_bug.cgi?id=673197#c5
Comment 9 neil@parkwaycc.co.uk 2011-07-31 02:28:35 PDT
I thought that this bug was about the build failing with gmake in a different way to pymake. If the build fails in the same way with both gmake and pymake then this bug is fixed, and any remaining issues are down to bug 674972.
Comment 10 Mike Pesce (:By-Tor) 2011-07-31 09:48:58 PDT
Everything appears to work as it should now.
Comment 11 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-11-02 08:47:33 PDT
Can we close this?
Comment 12 Mike Pesce (:By-Tor) 2011-11-02 08:52:55 PDT
I have no problems with closing this.  Any other problem would be a separate bug at this point.

Note You need to log in before you can comment on or make changes to this bug.