e10s websockets mochitests not run by buildbot

RESOLVED DUPLICATE of bug 668283

Status

defect
RESOLVED DUPLICATE of bug 668283
8 years ago
8 years ago

People

(Reporter: jduell.mcbugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
jmaher informs me that many mochitests under e10s fail, and the current solution for buildbot is to disable entire directories if any tests in them are failing.  This includes content/base/test, so our websockets tests aren't getting run under e10s (which is great until bug 537787 lands, since they'd break).

To enable just some tests in a directory, it sounds like we can hack the Makefile.in to only run failing tests if "ifneq (mobile,$(MOZ_BUILD_APP))" (for example see

  http://mxr.mozilla.org/mozilla-central/source/toolkit/components/places/tests/Makefile.in#76

Once we've excluded failing tests and can run content/base/test under e10s w/o errors, we can modify 

   http://mxr.mozilla.org/build/source/buildbot-configs/mozilla-tests/config.py#437

to include it in the list of dirs to run.

Fun times.
this might be a dup of bug 668283.
(Reporter)

Comment 2

8 years ago
> this might be a dup of bug 668283.

It looks like it.  The only thing I'm unclear about is how that bug is passing the websockets tests on fennec, unless jdm's testing with his e10s patch applied.  If that's true, we should DUPE this.
Yes, I've been testing on top of my e10s patches.
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668283
You need to log in before you can comment on or make changes to this bug.