wcap not working since TB5 and Lightning 1.0b4rc2

RESOLVED FIXED in 1.0b5

Status

defect
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: serge.spader, Assigned: mmecca)

Tracking

Lightning 1.0b4
1.0b5
x86
All
Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(1 attachment, 1 obsolete attachment)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Recently upgraded to TB5 and latest Lightning 1.0b4rc2


Actual results:

I see the warning triangle and "The calendar xxx is momentarily not available" when I try to view the Wcap calendar.
it worked before changing and it works with Google Calendar.
OS: Other → Windows XP
Hardware: All → x86
Today I upgraded to TB5 and latest Lightning 1.0b4. Results : I have the same bug. My wcap doesn't work

It works with Google Calendar.

I downgrade with TB3 and  Lightning 1.0b2 and it works

warning log :

Avertissement : Une erreur est survenue lors de la lecture de données de l'agenda : PERRIN Valentin. Cependant, l'erreur est certainement mineure ; le programme va donc essayer de poursuivre. Code d'erreur : 0x80004005. Description : NS_ERROR_FAILURE

and 

Avertissement : Une erreur est survenue lors de la lecture de données de l'agenda : PERRIN Valentin. Cependant, l'erreur est certainement mineure ; le programme va donc essayer de poursuivre. Code d'erreur : READ_FAILED. Description : READ_FAILED
Unfortunately we don't have a wcap server to test this. Could you provide us with one?
I couldn't provide a wcap server (it's a work server) but i can give you a file log if you explain me how to activate the error mode log of lightning
I can tell you how to enable, but tbh I probably can't make much of it. Anyway:

Options > Adanced > General > Config Editor.

Then, set:

calendar.wcap.log_level = 99
calendar.debug.log = true
calebndar.debug.log.verbose = true
I found the bug.

In the file /calendar-js/calWcapCalendarItems.js,  I found this :

cal.processPendingEvent; on line  977, 1013 and 1061

But this function have disappear since a previous version.

I tried to comment this call function and it's works.

if you want i have attache the correct file on this topic

Sorry for my english. I'm french.
Same behaviour seen in Bielefeld.
Seems like processPendingEvent was defined in modules/CalUtils.jsm (checked on pre3 build 2011-03-28) and disappeared.
Simple grep on subfolder of extension now just yields the mentioned calls, no function header.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: Lightning 1.0b2 → Lightning 1.0b4
Perfect, sounds like an easy fix, seems I forgot to remove all traces of that function. I'll need a patch in mercurials diff format with http://hg.mozilla.org/comm-central, then I can push it. If someone wants to do this for me, I'd appreciate. Otherwise I'll put this on my todo list.
Severity: normal → major
Flags: blocking-calendar1.0?
OS: Windows XP → All
Flags: wanted-calendar1.0?
Flags: wanted-calendar1.0?
Flags: blocking-calendar1.0?
Flags: blocking-calendar1.0+
Whiteboard: [needed beta][no l10n impact]
Posted patch patch v1Splinter Review
Attachment #544095 - Flags: review?(philipp)
Comment on attachment 544095 [details] [diff] [review]
patch v1

These are the changes from comment #5, but I don't have access to a wcap server to test if this fixes the problem or not.
Assignee: nobody → matthew.mecca
Status: NEW → ASSIGNED
Got feedback from a few users on a 'comment out the calls patch' for a couple of days. They report to have seen no negative effects yet.
@Philipp Kewisch: Test accounts on wcap server provided some time ago are still valid. You are welcome to use them for development/debugging purposes.
I manually change the file calWcapCalendarItems.js in the same way as Tarti did in comment #5 and my access to our Calendar Server is well back.
Jens, thanks for the note. I forgot I had them and will look in my emails. Anyway, I think since enough people have tested this its ok to take the patch. This will be included in the 1.0b5 release which is due in the next week (urgent bugfix release)
FYI we had exactly the same bug and the fix is working for us now. Hope it will be embeded in a next release. Thanks a lot for your prompt reactivity.
Comment on attachment 544095 [details] [diff] [review]
patch v1

Looks good and seems to work just fine! r=mschroeder
Attachment #544095 - Flags: review?(philipp) → review+
Attachment #543077 - Attachment is obsolete: true
Hi, I had the same bug, the solution from Tarti worked fine for me.
thanks to all.
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/8961a80e383c>
-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
Backported to comm-miramar <http://hg.mozilla.org/releases/comm-miramar/rev/c69062fc3779>
Target Milestone: Trunk → 1.0b5
Duplicate of this bug: 670135
You need to log in before you can comment on or make changes to this bug.