Last Comment Bug 668184 - Make nsIDocument::AddXMLEventsContent return void
: Make nsIDocument::AddXMLEventsContent return void
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-29 05:00 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-09-20 06:19 PDT (History)
2 users (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.63 KB, patch)
2011-06-29 05:00 PDT, :Ms2ger (⌚ UTC+1/+2)
bugs: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-06-29 05:00:22 PDT
Created attachment 542776 [details] [diff] [review]
Patch v1

None of its callers check the return value, which can only be NS_OK because of infallible new.
Comment 1 Olli Pettay [:smaug] 2011-06-29 05:18:09 PDT
Comment on attachment 542776 [details] [diff] [review]
Patch v1

You need to update the IID of nsIDocument
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2011-07-03 08:09:33 PDT
http://hg.mozilla.org/mozilla-central/rev/4caf28f35715
Comment 3 Ioana (away) 2011-09-20 06:19:15 PDT
From the code changes made to:
content/base/public/nsIDocument.h
content/base/src/nsDocument.cpp
content/base/src/nsDocument.h

it is obvious that AddXMLEventsContent now returns void instead of nsresult.

Note You need to log in before you can comment on or make changes to this bug.