Closed Bug 668355 Opened 9 years ago Closed 9 years ago

Measure plugin enumeration with telemetry

Categories

(Core :: Plug-ins, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla7

People

(Reporter: taras.mozilla, Unassigned)

References

Details

(Whiteboard: [inbound])

Attachments

(2 files, 2 obsolete files)

No description provided.
Attached patch raii helper (obsolete) — Splinter Review
Attachment #542953 - Flags: review?(mh+mozilla)
Attached patch telemetry for addon scanning (obsolete) — Splinter Review
This measures time spent on enumeration.
As far as I can tell .javaEnabled is the leading trigger of plugin enumeration. This should confirm it.
Attachment #542958 - Flags: review?(joshmoz)
Comment on attachment 542953 [details] [diff] [review]
raii helper

Review of attachment 542953 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/components/telemetry/Telemetry.h
@@ +75,5 @@
> +
> +private:
> +  const ID id;
> +  const TimeStamp start;
> +};

I think this would also work with something like:
template <int id>
class Timer {
public:
   Timer(): start(TimeStamp::Now()) {}
   ~Timer() { Accumulate(ID(id), (TimeStamp::Now() - start).ToMilliseconds()); }

private:
   const TimeStamp start;
};

In practice, with compiler optimizations, I'm not sure it would make any difference, though. (except in debug builds where we build without optimization)
Attachment #542953 - Flags: review?(mh+mozilla) → review+
Attached patch raii helperSplinter Review
Template suggestion makes using this brilliant. Thanks.
Attachment #542953 - Attachment is obsolete: true
Attachment #543285 - Flags: review+
Updated with template change
Attachment #542958 - Attachment is obsolete: true
Attachment #543286 - Flags: review?(joshmoz)
Attachment #542958 - Flags: review?(joshmoz)
Josh, I would appreciate a quick review on this. Would be good to get some wider coverage on plugin overhead in released versions in firefox(since we are merging soon)
Comment on attachment 543286 [details] [diff] [review]
telemetry for addon scanning

This looks fine to me, although I'd prefer Telemetry::Timer were called AutoTimer to emphasize the fact that it's RAII.
Attachment #543286 - Flags: review?(joshmoz) → review+
Would be nicer if this were AutoTimer to match our RAII naming conventions.
(In reply to comment #9)
> Would be nicer if this were AutoTimer to match our RAII naming conventions.

ok since there are two votes, I'll change it in a followup.
(In reply to comment #9)
> Would be nicer if this were AutoTimer to match our RAII naming conventions.

http://hg.mozilla.org/integration/mozilla-inbound/rev/0d425ab8eb13
You need to log in before you can comment on or make changes to this bug.