when opening the local trash folder (on first delete) batch the updates to the unread count

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P2
normal
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

({perf})

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

try this:

have 1000 unread messages in your trash
start up, don't load the trash, select your inbox.
delete a message.

deleting a message causes us to open the trash.  we'll update the unread count
once per message, instead of in batch.
happens to me every time I start up and delete a message, since I've got unread
mail in my trash.
Status: NEW → ASSIGNED
Keywords: perf
Target Milestone: --- → mozilla0.8

Comment 2

17 years ago
Are you talking about IMAP? We should not be issuing an IMAP select when
deleting a message to the trash, and it sounds like you're saying we do. If so,
that's a regression.
QA Contact: esther → sheelar
this was on pop.  I'll double check what happens for imap.

Updated

17 years ago
Summary: when opening the trash folder (on first delete) batch the updates to the unread count → when opening the local trash folder (on first delete) batch the updates to the unread count

Comment 4

17 years ago
ah, ok, that makes sense, and I've seen it happen as well. What's happening is
that attempting to open the trash db is causing the trash folder to get reparsed
and the db recreated. Batching the count updates would be a fine thing to do.
The trash db should not be gettng out of sync as often as it is, however.
naving may have fixed this.

naving, did you make it so we don't open the trash folder on delete?

Comment 6

17 years ago
No, Navin made it so we don't download imap headers for the trash on undo. We
still open the db (and we need to).

Comment 7

17 years ago
moving to mozilla0.9
Target Milestone: mozilla0.8 → mozilla0.9

Comment 8

17 years ago
marking nsbeta1+.
Keywords: nsbeta1
Whiteboard: [nsbeta1+]

Updated

17 years ago
Priority: -- → P2

Updated

17 years ago
Target Milestone: mozilla0.9 → mozilla0.9.1

Comment 9

17 years ago
Are you still seeing this?  I've been playing around with my Local Folders trash
folder and it never seems to need to be reparse.  I have 1083 unread messages.

Comment 10

17 years ago
I fixed a few problems that were causing the trash folder+db to get out of sync
so this should be much harder to recreate.

Comment 11

17 years ago
Great.  Then moving to 0.9.2.  If what's left is still noticeable then we can
fix it then or else I'll just move this to the future milestone.
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 12

17 years ago
moving to 0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 13

17 years ago
moving to 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4
slide to 0.9.5
Target Milestone: mozilla0.9.4 → mozilla0.9.5
moving out.
Target Milestone: mozilla0.9.5 → mozilla0.9.7

Updated

16 years ago
Blocks: 104166
QA Contact: sheelar → stephend
Hardware: PC → All

Comment 16

16 years ago
moving to future.  If you think this is something that needs to be fixed (it
sounds like we've reduced the potential cases where this could happen), let me know.
Keywords: nsbeta1-
Whiteboard: [nsbeta1+]
Target Milestone: mozilla0.9.7 → Future

Comment 17

16 years ago
I had 1000 unread of 7000 messages in my trash, and noticed that the first
delete was always slow (1-2 seconds).  After reading this bug, I tried marking
all the messages in my trash as unread and restarting, but deleting the first
message is still slow.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Status: ASSIGNED → NEW

Comment 18

10 years ago
problem gone?   was this pop-only (comment 3)?
QA Contact: stephend

Comment 19

10 years ago
I don't see this, perhaps due to comment 10 or other similar fixes.

Comment 20

10 years ago
=> WFM per andrew
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.