If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

How Stuff Works demo is slower with Azure

RESOLVED DUPLICATE of bug 667461

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 667461
6 years ago
4 years ago

People

(Reporter: icecold, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
With gfx.canvas.azure.enabled enabled by default, Firefox is slower on How Stuff Works demo than with gfx.canvas.azure.enabled disabled.
With Azure it should be at the same performance or better.

Some numbers:

Latest Nightly with Azure enabled

Revolutions per minute - around 33
Average draw time - around 82ms

Latest Nightly with Azure disabled

Revolutions per minute - around 46
Average draw time - around 57ms
(Reporter)

Comment 1

6 years ago
http://ie.microsoft.com/testdrive/Graphics/HowStuffWorksGears/Default.html
(Reporter)

Updated

6 years ago
Keywords: regression
Blocks: 651858
I can confirm.

Comment 3

6 years ago
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110630 Firefox/7.0a1


I can't confirm with latest hourly, work fine for me. Maybe its fixed by 667461, that was landed some hours ago:

http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1309431509/


Azure Disabled:

Revolutions per minute - 66,372
Average draw time - 34ms


Azure Enabled:

Revolutions per minute - 80,162
Average draw time - 22ms
Status: UNCONFIRMED → NEW
tracking-firefox7: --- → ?
Ever confirmed: true
(Reporter)

Comment 4

6 years ago
(In reply to comment #3)
> User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110630
> Firefox/7.0a1
> 
> 
> I can't confirm with latest hourly, work fine for me. Maybe its fixed by
> 667461, that was landed some hours ago:
> 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-
> central-win32/1309431509/
> 
> 
> Azure Disabled:
> 
> Revolutions per minute - 66,372
> Average draw time - 34ms
> 
> 
> Azure Enabled:
> 
> Revolutions per minute - 80,162
> Average draw time - 22ms
Yup, seems to be fixed by 667461. 
We're even getting little bit better score than IE10 Platform Preview 2.
Marking this bug as duplicate of 667461.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 667461

Updated

6 years ago
tracking-firefox7: ? → ---
You need to log in before you can comment on or make changes to this bug.