App tabs shouldn't let one change the URL

RESOLVED DUPLICATE of bug 607266

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 607266
7 years ago
6 years ago

People

(Reporter: Navid, Unassigned)

Tracking

5 Branch
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Created a Facebook App tab.  Then while on that App tab, I wanted to go to a new site, and typed the new URL not noticing that I was on that App tab.  Then later I tried finding my Facebook App tab, and I couldn't find it, because the App tab had switched to the other website.

I believed the notion of the App tab was that it was always there, but allowing one to navigate away from it can be confusing.


Actual results:

My original App tab changed to a website that I didn't want an App tab for


Expected results:

Firefox should not let a user change the URL of an apptab.  Links within that URL should stay within the App tab, and the URL shown.

Comment 1

6 years ago
If you only want to disallow changing the URL manually, then that is bug 607266.
If you want the new URL to open in a new tab, then vote in bug 598587.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 607266
You need to log in before you can comment on or make changes to this bug.