The default bug view has changed. See this FAQ.

Fixed position layers has been broken in 637852

RESOLVED FIXED in mozilla8

Status

()

Core
Layout
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: romaxa, Assigned: romaxa)

Tracking

Trunk
mozilla8
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
I've checked latest nightly and found that 
MOZ_ENABLE_FIXED_POSITION_LAYERS=1  ./fennec https://bugzilla.mozilla.org/attachment.cgi?id=486294

does not work anymore.... fixed layers are moving (fixed layer are moving async with fennec scrolling)

Found regression in:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7a93f1279b7&tochange=48e72227c2fa

Most likely it is coming from bug 637852
(Assignee)

Comment 1

6 years ago
Created attachment 549222 [details] [diff] [review]
Make fixed pos layers working again
Assignee: nobody → romaxa
Status: NEW → ASSIGNED
Attachment #549222 - Flags: review?(ben)
Comment on attachment 549222 [details] [diff] [review]
Make fixed pos layers working again

Can you explain why the divide is a multiply now?
Attachment #549222 - Flags: review?(ben)
Attachment #549222 - Flags: review+
(Assignee)

Comment 3

6 years ago
Because new scale values are 1/scale, so I decided to kill double divide and use multiply.
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
http://hg.mozilla.org/integration/mozilla-inbound/rev/b8ea31e6eeb4
Keywords: checkin-needed
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/b8ea31e6eeb4
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla8
Duplicate of this bug: 650759
You need to log in before you can comment on or make changes to this bug.