Last Comment Bug 668919 - The ellipsis with text-overflow: ellipsis is sometimes one pixel too low
: The ellipsis with text-overflow: ellipsis is sometimes one pixel too low
Status: RESOLVED FIXED
[inbound]
: pp, testcase
Product: Core
Classification: Components
Component: Layout: Block and Inline (show other bugs)
: unspecified
: All Mac OS X
: -- normal (vote)
: mozilla7
Assigned To: Mats Palmgren (:mats)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-01 16:12 PDT by Patrick Walton (:pcwalton)
Modified: 2013-12-27 14:20 PST (History)
3 users (show)
mats: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Incorrect rendering for second row of tabs and below (134.76 KB, image/png)
2011-07-01 16:14 PDT, Patrick Walton (:pcwalton)
no flags Details
Correct rendering for second row of tabs and below (135.89 KB, image/png)
2011-07-01 16:14 PDT, Patrick Walton (:pcwalton)
no flags Details
Testcase #1 (1009 bytes, text/html)
2011-07-01 17:42 PDT, Mats Palmgren (:mats)
no flags Details
fix + reftest, rev. 1 (14.06 KB, patch)
2011-07-02 15:22 PDT, Mats Palmgren (:mats)
roc: review+
Details | Diff | Splinter Review

Description Patrick Walton (:pcwalton) 2011-07-01 16:12:56 PDT
Screenshots of Panorama attached. Sometimes the ellipsis is one pixel too low for me, depending on the block sizing, but not always.
Comment 1 Patrick Walton (:pcwalton) 2011-07-01 16:14:07 PDT
Created attachment 543533 [details]
Incorrect rendering for second row of tabs and below
Comment 2 Patrick Walton (:pcwalton) 2011-07-01 16:14:28 PDT
Created attachment 543534 [details]
Correct rendering for second row of tabs and below
Comment 3 Mats Palmgren (:mats) 2011-07-01 16:44:10 PDT
WFM in a local Linux64 mozilla-central build.  I can reproduce it on OSX
though.  A testcase would help debugging... do you know what kind of markup
are used for the text there?
Comment 5 Mats Palmgren (:mats) 2011-07-01 17:42:50 PDT
Created attachment 543547 [details]
Testcase #1
Comment 6 Mats Palmgren (:mats) 2011-07-01 17:47:24 PDT
Testcase #1 looks fine on Linux on Windows XP.  Also when zooming up/down.

On OSX, the top three lines looks fine, on the next four the ellipsis is
too low, the bottom four looks good.
Comment 7 Mats Palmgren (:mats) 2011-07-01 17:48:02 PDT
s/Linux on Windows/Linux and Windows/
Comment 8 Patrick Walton (:pcwalton) 2011-07-01 17:48:42 PDT
Confirmed on Mac.
Comment 9 Mats Palmgren (:mats) 2011-07-02 01:47:59 PDT
The problem is that nsTextFrame pixel-snaps the baseline.y before painting
the text, and we need to do the same when painting the marker text.
Should be an easy fix, just factoring out nsTextFrame::GetSnappedBaselineY
to nsLayoutUtils...
Comment 10 Mats Palmgren (:mats) 2011-07-02 15:22:56 PDT
Created attachment 543626 [details] [diff] [review]
fix + reftest, rev. 1
Comment 11 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-07-03 20:33:06 PDT
Comment on attachment 543626 [details] [diff] [review]
fix + reftest, rev. 1

Review of attachment 543626 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 13 Marco Bonardo [::mak] 2011-07-04 11:42:41 PDT
http://hg.mozilla.org/mozilla-central/rev/cdff167e8074

Note You need to log in before you can comment on or make changes to this bug.