The default bug view has changed. See this FAQ.

.response with .responseType='blob' doesn't work correctly for large remote file

VERIFIED FIXED in Firefox 6

Status

()

Core
DOM
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: emk, Assigned: khuey)

Tracking

unspecified
mozilla9
Points:
---

Firefox Tracking Flags

(firefox5 unaffected, firefox6 fixed, firefox7 fixed, firefox8 fixed)

Details

(Whiteboard: [qa!], URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
See bug 661582 comment #19.
(Reporter)

Comment 1

6 years ago
Unfortunately my build environment is broken at the moment. I'm not sure I can write a patch for this bug...
(Reporter)

Comment 2

6 years ago
> I'm not sure I can write a patch for this bug...
until next aurora merge.
(Reporter)

Comment 3

6 years ago
I think we should disable .responseType='blob' support on Firefox 6 unless this bug is fixed.
Created attachment 545283 [details] [diff] [review]
Forgo the cache optimization for correctness.
Attachment #545283 - Flags: review?(jonas)
Comment on attachment 545283 [details] [diff] [review]
Forgo the cache optimization for correctness.

Review of attachment 545283 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #545283 - Flags: review?(jonas) → review+
status-firefox5: --- → unaffected
Comment on attachment 545283 [details] [diff] [review]
Forgo the cache optimization for correctness.

Drivers, this patch removes an optimization that still has some problems.  We should take this patch for Firefox 6 and 7, and fix this bug correctly for Firefox 8.
Attachment #545283 - Flags: approval-mozilla-beta?
Attachment #545283 - Flags: approval-mozilla-aurora?

Updated

6 years ago
Whiteboard: [temp workaround to avoid disabling .responseType='blob']

Updated

6 years ago
Attachment #545283 - Flags: approval-mozilla-beta?
Attachment #545283 - Flags: approval-mozilla-beta+
Attachment #545283 - Flags: approval-mozilla-aurora?
Attachment #545283 - Flags: approval-mozilla-aurora+

Comment 7

6 years ago
Kyle, can you land this today?
http://hg.mozilla.org/releases/mozilla-aurora/rev/9e82442fe643
http://hg.mozilla.org/releases/mozilla-beta/rev/8d3fafa80d4b

Leaving the bug open because I still need to fix this on 8.
status-firefox6: --- → fixed
status-firefox7: --- → fixed
status-firefox8: --- → affected
Comment on attachment 545283 [details] [diff] [review]
Forgo the cache optimization for correctness.

I forgot to fix this on trunk before the merge, so we'll need to check the bandaid into aurora again :-/
Attachment #545283 - Flags: approval-mozilla-aurora+ → approval-mozilla-aurora?
Comment on attachment 545283 [details] [diff] [review]
Forgo the cache optimization for correctness.

Approved on the assumption that this is the same bandaid we have shipped in 6 and 7, and with the fervent hope that we get the for real fix in soon!
Attachment #545283 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Didn't my real fix land on trunk in time to fix this too?
(Reporter)

Comment 12

6 years ago
Yeah, attachment 543659 [details] works on Aurora 8.0a2. The root cause has been fixed by bug 669433. So we don't have to apply the bandaid anymore.
But we should add attachment 543659 [details] as an automated test to prevent further regressions.
status-firefox8: affected → fixed
http://hg.mozilla.org/releases/mozilla-aurora/rev/2bdd9c852f54
Assignee: nobody → khuey
(In reply to Jonas Sicking (:sicking) from comment #11)
> Didn't my real fix land on trunk in time to fix this too?

Oh, I thought there was more to do here :-/
http://hg.mozilla.org/releases/mozilla-aurora/rev/7d122e5b3455

I backed this out of Aurora.
(Reporter)

Comment 16

6 years ago
Created attachment 561902 [details] [diff] [review]
automated test
Attachment #561902 - Flags: review?(jonas)
(Reporter)

Comment 17

6 years ago
Created attachment 562268 [details] [diff] [review]
rebased to tip
Attachment #561902 - Attachment is obsolete: true
Attachment #562268 - Flags: review?(jonas)
Attachment #561902 - Flags: review?(jonas)
Comment on attachment 562268 [details] [diff] [review]
rebased to tip

Review of attachment 562268 [details] [diff] [review]:
-----------------------------------------------------------------

I think the new tests in test_xhr_progressevents somewhat covers this case. Though it explicitly disables caching, so maybe it's best to take this one too.
Attachment #562268 - Flags: review?(jonas) → review+
(Reporter)

Updated

6 years ago
Keywords: checkin-needed
Whiteboard: [temp workaround to avoid disabling .responseType='blob']
https://hg.mozilla.org/integration/mozilla-inbound/rev/fb91c8798858
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/fb91c8798858
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla9

Comment 21

6 years ago
Verified that the automated for this bug test has passed on Linux, Mac, Win 7 and Win XP:
Fx beta (8b1)
https://tbpl.mozilla.org/php/getParsedLog.php?id=6675073&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6663377&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6660944&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6675039&full=1

Fx aurora (9a2) 
https://tbpl.mozilla.org/php/getParsedLog.php?id=6673423&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6675104&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6674870&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6674891&full=1

Fx central (10a1)
https://tbpl.mozilla.org/php/getParsedLog.php?id=6680926&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6681523&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6681795&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6681778&full=1

Fx release
https://tbpl.mozilla.org/php/getParsedLog.php?id=6613063&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6614891&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6598770&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=6598944&full=1
Status: RESOLVED → VERIFIED

Updated

6 years ago
Whiteboard: [qa!]
You need to log in before you can comment on or make changes to this bug.