Last Comment Bug 669138 - submitting .<thai> IDNccTLD
: submitting .<thai> IDNccTLD
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: unspecified
: All Other
: -- normal (vote)
: mozilla13
Assigned To: Gervase Markham [:gerv]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-04 02:49 PDT by Parkpoom T.
Modified: 2012-03-29 15:42 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Patch v.1 (1004 bytes, patch)
2012-02-27 05:04 PST, Gervase Markham [:gerv]
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Parkpoom T. 2011-07-04 02:49:58 PDT
User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1

Steps to reproduce:

TLD: .ไทย  (.<thai>)
Punny code: .xn--o3cw4h
Registration Page: www.thnic.co.th
Policy Page: https://www.thnic.co.th/index.php?page=policy_dotthai
Character List: http://www.iana.org/domains/idn-tables/tables/th_th-th_1.0.html

Submit by: Parkpoom Tripatana
Role: Registry & Registrar Managing Director
email: parkpoom@thnic.co.th
Comment 1 Jothan Frakes 2011-07-05 15:43:23 PDT
I spoke with Parkpoom in Singapore at the ICANN Meeting about submitting this, and he quickly submitted this.

They register equivalent domain between both TLDs, so policies and codepoints are identical between .th and .ไทย. 

Dot .th is in the approved list already.  This is literally cloning it
Comment 2 Gervase Markham [:gerv] 2012-02-21 10:08:17 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/fadf8e80a3f2

Gerv
Comment 3 Ed Morley [:emorley] 2012-02-22 10:49:19 PST
https://hg.mozilla.org/mozilla-central/rev/fadf8e80a3f2
Comment 4 Gervase Markham [:gerv] 2012-02-27 05:04:10 PST
Created attachment 600871 [details] [diff] [review]
Patch v.1
Comment 5 Gervase Markham [:gerv] 2012-02-27 05:06:18 PST
Comment on attachment 600871 [details] [diff] [review]
Patch v.1

[Approval Request Comment]
User impact if declined: IDNs not working (displaying as gibberish) in relevant domain.
Testing completed (on m-c, etc.): Policy rather than code change; but patch has baked over the weekend.
Risk to taking this patch (and alternatives if risky): Very low.
String changes made by this patch: None.

Gerv
Comment 6 Alex Keybl [:akeybl] 2012-02-27 15:30:27 PST
Comment on attachment 600871 [details] [diff] [review]
Patch v.1

[Triage Comment]
Assuming this has gone through all the proper processes, approving for Aurora 12 and Beta 11. We do not expect to see any regressions caused by this patch which, as Gerv notes, is really just policy change.

Note You need to log in before you can comment on or make changes to this bug.