Restore backup connection for IPv6-only hosts

RESOLVED DUPLICATE of bug 684893

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 684893
7 years ago
2 years ago

People

(Reporter: Biesinger, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [http-conn])

See 621558 comment 9 - I've come to the conclusion that this is actually doable without too much difficulty.

Implementation sketch:
- Add an attribute + member variable isIpv6Only to socket transport. default to false (needed when we don't do DNS resolution, e.g. for SOCKS)
- when DNS resolution is done, iterate over the DNS record and store whether it is v6-only
- when the backup connection gets set up, read that property from the main connection to figure out whether to disable v6 or not
Keywords: dev-doc-needed
Whiteboard: [http-conn]
may be a duplicate of the bug Patrick mentioned, but either way, I'm not working on this one...
Assignee: cbiesinger → nobody
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684893
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.