Closed Bug 669366 Opened 10 years ago Closed 10 years ago

Handle negative arguments to drawImage

Categories

(Core :: Canvas: 2D, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Tracking Status
firefox5 + fixed
firefox6 --- fixed
firefox7 + fixed

People

(Reporter: christian, Assigned: jrmuizel)

References

()

Details

(4 keywords, Whiteboard: [qa!])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #629875 +++

http://www.w3c-test.org/html/tests/submission/PhilipTaylor/canvas/2d.drawImage.negativedest.html
http://www.w3c-test.org/html/tests/submission/PhilipTaylor/canvas/2d.drawImage.negativedir.html
http://www.w3c-test.org/html/tests/submission/PhilipTaylor/canvas/2d.drawImage.negativesource.html

We need to figure out if we want the backout on Aurora as we didn't transplant anything in the source migration (didn't transplant cleanly)
So, should we get attachment 533887 [details] [diff] [review] reviewed and landed?
JP, can you help find the right people to look at this?
Jeff probably has the most context.
Assignee: nobody → jmuizelaar
Yes, I believe we should land the backout on Aurora. I'll take a closer look at this today.
This patch will switch Azure to the old behavior.
I pushed this and the reversion of bug 629875 to aurora:

http://hg.mozilla.org/releases/mozilla-aurora/rev/20e76c984d82

and to inbound:

http://hg.mozilla.org/integration/mozilla-inbound/rev/b9ad0b9119b7
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
This was documented a while ago.
qa+ for verification in Firefox 7
Whiteboard: [qa+]
Verified using the links from the description in Win XP, Win 7, Mac OS X 10.6 and Ubuntu 11.04 on Firefox 7RC, Aurora and the latest Nightly. On all of the 3 links the results are Failed on a red Background, this is the intended behavior as this is a backout.

Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0) Gecko/20100101 Firefox/7.0

Mozilla/5.0 (Windows NT 5.1; rv:8.0a2) Gecko/20110921 Firefox/8.0a2
Mozilla/5.0 (Windows NT 6.1; rv:8.0a2) Gecko/20110921 Firefox/8.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a2) Gecko/20110921 Firefox/8.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a2) Gecko/20110921 Firefox/8.0a2

Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110922 Firefox/9.0a1
Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110922 Firefox/9.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110922 Firefox/9.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a1) Gecko/20110923 Firefox/9.0a1
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.