Last Comment Bug 669366 - Handle negative arguments to drawImage
: Handle negative arguments to drawImage
Status: VERIFIED FIXED
[qa!]
: dev-doc-complete, html5, verified-aurora, verified-beta
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
http://www.whatwg.org/html/#dom-conte...
Depends on: 629875 655328
Blocks: 622842
  Show dependency treegraph
 
Reported: 2011-07-05 10:39 PDT by christian
Modified: 2013-12-27 14:28 PST (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
fixed
+
fixed


Attachments
Switch Azure to old behavior (1.70 KB, patch)
2011-07-14 16:04 PDT, Bas Schouten (:bas.schouten)
no flags Details | Diff | Splinter Review

Description christian 2011-07-05 10:39:31 PDT
+++ This bug was initially created as a clone of Bug #629875 +++

http://www.w3c-test.org/html/tests/submission/PhilipTaylor/canvas/2d.drawImage.negativedest.html
http://www.w3c-test.org/html/tests/submission/PhilipTaylor/canvas/2d.drawImage.negativedir.html
http://www.w3c-test.org/html/tests/submission/PhilipTaylor/canvas/2d.drawImage.negativesource.html

We need to figure out if we want the backout on Aurora as we didn't transplant anything in the source migration (didn't transplant cleanly)
Comment 1 :Ms2ger 2011-07-05 11:59:29 PDT
So, should we get attachment 533887 [details] [diff] [review] reviewed and landed?
Comment 2 Asa Dotzler [:asa] 2011-07-13 12:04:10 PDT
JP, can you help find the right people to look at this?
Comment 3 JP Rosevear [:jpr] 2011-07-14 06:00:01 PDT
Jeff probably has the most context.
Comment 4 Jeff Muizelaar [:jrmuizel] 2011-07-14 08:03:58 PDT
Yes, I believe we should land the backout on Aurora. I'll take a closer look at this today.
Comment 5 Bas Schouten (:bas.schouten) 2011-07-14 16:04:21 PDT
Created attachment 546030 [details] [diff] [review]
Switch Azure to old behavior

This patch will switch Azure to the old behavior.
Comment 6 Joe Drew (not getting mail) 2011-07-22 12:42:23 PDT
I pushed this and the reversion of bug 629875 to aurora:

http://hg.mozilla.org/releases/mozilla-aurora/rev/20e76c984d82

and to inbound:

http://hg.mozilla.org/integration/mozilla-inbound/rev/b9ad0b9119b7
Comment 7 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-07-25 06:00:22 PDT
http://hg.mozilla.org/mozilla-central/rev/b9ad0b9119b7
Comment 8 Eric Shepherd [:sheppy] 2011-08-05 11:09:01 PDT
This was documented a while ago.
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-09-22 15:49:56 PDT
qa+ for verification in Firefox 7
Comment 10 Simona B [:simonab] 2011-09-23 06:29:38 PDT
Verified using the links from the description in Win XP, Win 7, Mac OS X 10.6 and Ubuntu 11.04 on Firefox 7RC, Aurora and the latest Nightly. On all of the 3 links the results are Failed on a red Background, this is the intended behavior as this is a backout.

Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0) Gecko/20100101 Firefox/7.0

Mozilla/5.0 (Windows NT 5.1; rv:8.0a2) Gecko/20110921 Firefox/8.0a2
Mozilla/5.0 (Windows NT 6.1; rv:8.0a2) Gecko/20110921 Firefox/8.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a2) Gecko/20110921 Firefox/8.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a2) Gecko/20110921 Firefox/8.0a2

Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110922 Firefox/9.0a1
Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110922 Firefox/9.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110922 Firefox/9.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a1) Gecko/20110923 Firefox/9.0a1

Note You need to log in before you can comment on or make changes to this bug.