The default bug view has changed. See this FAQ.

Build both VC9 and VC10 exception-wrapping code

RESOLVED FIXED in mozilla9

Status

()

Core
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: cjones, Assigned: cjones)

Tracking

Trunk
mozilla9
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

It was reported on m.d.build that our SDK doesn't build with VC10, because of our exception-wrapping code.  The problem is that we conditionally include the VC9 or VC10 headers/sources, and that depends on the machine the SDK was packaged on.  Hopefully we can move to VC10 ASAP, but in the meantime we should just build both into gecko.  They shouldn't conflict, in theory.
Created attachment 544055 [details] [diff] [review]
Always build both VC9 and VC10 exception-wrapping hackery into the Gecko SDK
Assignee: nobody → jones.chris.g
Attachment #544055 - Flags: review?(benjamin)
the actual patch is missing :)
Created attachment 544134 [details] [diff] [review]
Always build both VC9 and VC10 exception-wrapping hackery into the Gecko SDK

Oops, thanks.  Looks like hg let me qnew with unsaved changes.
Attachment #544055 - Attachment is obsolete: true
Attachment #544134 - Flags: review?(benjamin)
Attachment #544055 - Flags: review?(benjamin)
Attachment #544134 - Flags: review?(benjamin) → review+
http://hg.mozilla.org/integration/mozilla-inbound/rev/5c4506fdbde9
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/5c4506fdbde9
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla9
You need to log in before you can comment on or make changes to this bug.