Closed Bug 669535 Opened 10 years ago Closed 8 years ago

User pref for "Possible Duplicates"

Categories

(Bugzilla :: Creating/Changing Bugs, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Bugzilla 5.0

People

(Reporter: dvander, Assigned: sjoshi)

References

Details

Attachments

(1 file, 1 obsolete file)

It'd be nice if I could pref off "Possible Duplicates" for when I file bugs.

Whenever I'm filing a JS bug, I get this giant slorf of basically random stuff. The UI is disorienting, distracting, taking up what looks like about 30-40% of my screen. It's never found a valid dupe for me, and overhead of having and dealing with dupes in the system is super low anyway.
Assignee: nobody → create-and-change
Component: User Interface → Creating/Changing Bugs
Product: bugzilla.mozilla.org → Bugzilla
QA Contact: ui → default-qa
Version: Current → 4.0
Severity: normal → enhancement
Sounds like a reasonable request. If you want to fix this on your end in the mean time, I believe it's all contained in a div that a quick userContent.css change would hide from you.
Priority: -- → P3
Whiteboard: [Good Intro Bug]
Attached patch Patch-v1 (obsolete) — Splinter Review
Assignee: create-and-change → joshi_sunil
Status: NEW → ASSIGNED
Attachment #781070 - Flags: review?(dkl)
Comment on attachment 781070 [details] [diff] [review]
Patch-v1

>=== modified file 'template/en/default/bug/create/create.html.tmpl'

>+  [% IF feature_enabled('jsonrpc') AND !cloned_bug_id AND user.settings.possible_duplicates.value == 'on'%]

This line is too long, and there is a missing whitespace before %].



>=== modified file 'template/en/default/global/setting-descs.none.tmpl'

>+   "possible_duplicates"              => "Display possible duplicates while filling a new bug", 

while filling -> when reporting
bug -> $terms.bug
Attachment #781070 - Flags: review?(dkl) → review-
Attached patch Patch-v2Splinter Review
Review comments incorporated.
Attachment #781070 - Attachment is obsolete: true
Attachment #781774 - Flags: review?(dkl)
Comment on attachment 781774 [details] [diff] [review]
Patch-v2

Review of attachment 781774 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r=dkl

::: template/en/default/global/setting-descs.none.tmpl
@@ +47,1 @@
>                     } 

Nit: remove trailing whitespace on commit
Attachment #781774 - Flags: review?(dkl) → review+
Flags: approval?
I'm not sure about approving this one. If it was up to me, I would a-.

IMO, this is one of those 'features' that are better as an extension rather than part of the core code.

Thoughts?
Flags: needinfo?(justdave)
For what it's worth, I would still really appreciate seeing this option, especially on bmo.
(In reply to Simon Green from comment #6)
> IMO, this is one of those 'features' that are better as an extension rather
> than part of the core code.

The code is part of the core code. That's not what this bug is about. If you want to file a separate bug to move the Possible Duplicates code into an extension, feel free to do so. But even in that case, users may still want to not see it when the extension is enabled, so the current patch still makes sense.
Whiteboard: [Good Intro Bug]
Target Milestone: --- → Bugzilla 5.0
Flags: needinfo?(justdave)
Flags: approval?
Flags: approval+
Thanks for the patch!

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bugzilla/trunk
modified template/en/default/global/setting-descs.none.tmpl
modified Bugzilla/Install.pm
modified template/en/default/bug/create/create.html.tmpl
Committed revision 8693.  

dkl
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 678572
You need to log in before you can comment on or make changes to this bug.