text is replaced by ellipsis

VERIFIED INVALID

Status

()

Core
Layout
VERIFIED INVALID
7 years ago
7 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({testcase})

7 Branch
x86
Windows 7
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 544178 [details]
sample

Build Identifier:
http://hg.mozilla.org/releases/mozilla-aurora/rev/4310a4cfb3ae
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a2) Gecko/20110705 Firefox/7.0a2 ID:20110705154801

Text is replaced by ellipsis.

*This does not happen on Opera11.50, GoogleChrome12.0.742.112 and IE9
*This happens with / without Hardware Acceleration.

Reproducible: Always

Steps to Reproduce:
1. Open attached sample

Actual Results: 
  Text is replaced by ellipsis.

Expected Results:
  Text should display as same as the other browser.
The Actual Results is the intended behavior.

Note that other UAs implements an older version of the spec
http://www.w3.org/TR/2003/CR-css3-text-20030514/#text-overflow-props
where only "textual content" overflow triggered a marker.

The latest version of the spec
http://dev.w3.org/csswg/css3-ui/#text-overflow
says "when inline content overflows its block container".

The overflowing padding on your <span> is "inline content overflow".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Keywords: testcase
Resolution: --- → INVALID
(Reporter)

Comment 2

7 years ago
Created attachment 544185 [details]
sample2

Text displayed without truncate, but "..." displayed.

Is this same? but I think this looks strange.
Yes, the marker is triggered for the same reason, and then aligns to
the nearest text or atomic inline-level element on the line.

Please also note that other UAs do not implement markers at the start
of the line.  So even if you removed the padding to make the text overflow
on the start side there will be no marker in other UAs.
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED

Updated

7 years ago
Blocks: 312156

Comment 4

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111014 Firefox/10.0a1

"sample" is partly fixed
"sample2" is fixed with bug 684266
Depends on: 684266
You need to log in before you can comment on or make changes to this bug.