Last Comment Bug 669670 - Remove workaround for getOwnPropertyDescriptor from chrome code
: Remove workaround for getOwnPropertyDescriptor from chrome code
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 8
Assigned To: Panos Astithas [:past]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-06 09:33 PDT by Panos Astithas [:past]
Modified: 2011-07-08 07:51 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
[in-fx-team] Patch v1 (2.70 KB, patch)
2011-07-06 09:36 PDT, Panos Astithas [:past]
mihai.sucan: review+
dtownsend: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] 2011-07-06 09:33:52 PDT
In bug 651501 I used the pattern scope.Object.getOwnPropertyDescriptor to work around a platform bug. Since bug 664689 was fixed we no longer need this, which would simplify our code a bit.
Comment 1 Panos Astithas [:past] 2011-07-06 09:36:24 PDT
Created attachment 544273 [details] [diff] [review]
[in-fx-team] Patch v1
Comment 2 Mihai Sucan [:msucan] 2011-07-07 03:59:07 PDT
Comment on attachment 544273 [details] [diff] [review]
[in-fx-team] Patch v1

This looks fine. All tests pass locally!
Comment 3 Panos Astithas [:past] 2011-07-07 04:25:10 PDT
Comment on attachment 544273 [details] [diff] [review]
[in-fx-team] Patch v1

Thank you Mihai!
Dave can you review this cleanup of the patch you reviewed for bug 651501?
Comment 4 Mihai Sucan [:msucan] 2011-07-08 02:33:15 PDT
Comment on attachment 544273 [details] [diff] [review]
[in-fx-team] Patch v1

Pushed to:

http://hg.mozilla.org/integration/fx-team/rev/bad869718019
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-07-08 07:51:29 PDT
http://hg.mozilla.org/mozilla-central/rev/bad869718019

Note You need to log in before you can comment on or make changes to this bug.