Closed Bug 669715 Opened 8 years ago Closed 8 years ago

TI: fix ARM bustage

Categories

(Core :: JavaScript Engine, defect)

9 Branch
ARM
All
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox9 + fixed

People

(Reporter: bhackett, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: mobile, perf, regression)

Attachments

(2 files)

The TI -> TM merge broke most of the Android and Maemo mochitests and talos tests (which were not being run on the JM tinderbox, oops).  Disabling TI on ARM fixes this, but this is just a stopgap and we need to figure out what is crashing ARM.
Stopgap changeset to disable inference on ARM.

http://hg.mozilla.org/tracemonkey/rev/8570f783088c
using a build before the disable, I see fennec crashing and this is the crashdump that I see:
http://people.mozilla.org/~jmaher/android_dumps/52b96947-9f60-f7d4-30977068-797f8a56.dmp
http://people.mozilla.org/~jmaher/android_dumps/52b96947-9f60-f7d4-30977068-797f8a56.extra

fyi, this should be in crash-stats, but I couldn't find it.
This is causing a slowdown for ARM over the pre-TI state of affairs, so requesting tracking for mozilla9.
Keywords: mobile, perf, regression
OS: Mac OS X → All
Hardware: x86 → ARM
Version: unspecified → 9 Branch
Depends on: 684404
Attached patch WIPSplinter Review
Fix some ARM ABI-related test failures.  Blocked on an ilooping jit-test for now, due to breakage in the ARM assembler.  Filed bug 684404.
when flushing a pool, we were not resetting the number of elements since the last pool when there was nothing in the pool.
Still more to do here, but now that jit-tests are passing and jstests are almost passing it's good to get some Fennec tinderbox coverage for this stuff.

http://hg.mozilla.org/projects/jaegermonkey/rev/9459096a263a
http://hg.mozilla.org/projects/jaegermonkey/rev/b31b25125429
https://hg.mozilla.org/mozilla-central/rev/c943bbf9dac4
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.