Last Comment Bug 669975 - websocket ASSERTION: nsLoadGroup not thread-safe
: websocket ASSERTION: nsLoadGroup not thread-safe
Status: RESOLVED FIXED
[inbound][qa-]
:
Product: Core
Classification: Components
Component: Networking: WebSockets (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla8
Assigned To: Patrick McManus [:mcmanus]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-07 12:28 PDT by Patrick McManus [:mcmanus]
Modified: 2012-05-30 07:18 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
+
fixed
fixed


Attachments
patch v1 (1.82 KB, patch)
2011-07-07 12:30 PDT, Patrick McManus [:mcmanus]
mcmanus: review+
blizzard: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Patrick McManus [:mcmanus] 2011-07-07 12:28:52 PDT
over in bug 669819 a stack with this assertion was reported. It turns out to be a distraction from the real issue of that bug, so I am splitting them apart.

From https://bugzilla.mozilla.org/show_bug.cgi?id=669819#c7
"the real cause is a regression from 537787, mLoadGroup was supposed to be moved to a base class but was instead duplicated in both the base and derived classes.

It should also be proxy released as I mentioned in comment 6, but that's apparently only relevant on a corner case that isn't being tested."

From https://bugzilla.mozilla.org/show_bug.cgi?id=669819#c10

"r=jdm"

From https://bugzilla.mozilla.org/show_bug.cgi?id=669819#c11

jduell says a? aurora

"The e10s patch landed in aurora, and this fixes a relatively important yet simple bug in it."
Comment 1 Patrick McManus [:mcmanus] 2011-07-07 12:30:06 PDT
Created attachment 544586 [details] [diff] [review]
patch v1
Comment 2 Christopher Blizzard (:blizzard) 2011-07-07 14:38:45 PDT
Comment on attachment 544586 [details] [diff] [review]
patch v1

Approved for Aurora.
Comment 3 Christopher Blizzard (:blizzard) 2011-07-07 14:39:21 PDT
Tracking for Aurora / Firefox 7 because it's a new(ish) feature.
Comment 4 Marco Bonardo [::mak] 2011-07-08 05:54:37 PDT
http://hg.mozilla.org/mozilla-central/rev/82d7d9c93a07
Comment 5 Patrick McManus [:mcmanus] 2011-07-08 07:31:49 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/8f58f46715a2
Comment 6 Virgil Dicu [:virgil] [QA] 2011-08-19 08:25:28 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0

Could you provide a test case or some clear STRs in order to get this issue verified on QA side?
Comment 7 Patrick McManus [:mcmanus] 2011-08-19 09:55:00 PDT
the STR was a mochitest orange failure involving test_websocket_basic.html that has cleared up. comment 0 points to 669819 for the particular failure.
Comment 8 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-09-22 15:51:34 PDT
qa- as no QA fix verification needed

Note You need to log in before you can comment on or make changes to this bug.