Last Comment Bug 669979 - When two-finger Scrolling with the trackpad (with momentum), pressing Ctrl while scrolling finishes causes page zoom if pixel scrolling is disabled
: When two-finger Scrolling with the trackpad (with momentum), pressing Ctrl wh...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: Trunk
: All Mac OS X
: P1 normal (vote)
: mozilla8
Assigned To: Boris Zbarsky [:bz]
:
Mentors:
Depends on: 574663
Blocks: 605751
  Show dependency treegraph
 
Reported: 2011-07-07 12:43 PDT by Boris Zbarsky [:bz]
Modified: 2011-08-02 03:19 PDT (History)
20 users (show)
bzbarsky: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
final+


Attachments
Don't do zoom or history actions for momentum scrolls, no matter what's going on with pixel scrolling. (1.98 KB, patch)
2011-08-01 08:44 PDT, Boris Zbarsky [:bz]
bugs: review+
Details | Diff | Review
With the test change (2.81 KB, patch)
2011-08-01 09:05 PDT, Boris Zbarsky [:bz]
masayuki: review+
Details | Diff | Review

Description Boris Zbarsky [:bz] 2011-07-07 12:43:52 PDT
+++ This bug was initially created as a clone of Bug #574663 +++

This is just like bug 574663, but first you need to flip "mousewheel.enable_pixel_scrolling" to false in about:config.  It looks like the patches in bug 574663 only modified the pixel-scrolling codepaths....

I finally figured out today that this is what causes sites to randomly zoom for me.
Comment 1 Boris Zbarsky [:bz] 2011-08-01 08:44:27 PDT
Created attachment 549815 [details] [diff] [review]
Don't do zoom or history actions for momentum scrolls, no matter what's going on with pixel scrolling.
Comment 2 Markus Stange [:mstange] 2011-08-01 08:50:16 PDT
You could extend content/events/test/test_bug574663.html to test this, for example by adding another flag to sendTouchpadScrollMotion that makes it send one line scroll with hasPixels = false instead of what it currently does.
Comment 3 Boris Zbarsky [:bz] 2011-08-01 08:51:43 PDT
Hmm.   Let me give that a shot!
Comment 4 Boris Zbarsky [:bz] 2011-08-01 09:05:09 PDT
Created attachment 549820 [details] [diff] [review]
With the test change

Verified that the changed test fails without the code change and passes with it.
Comment 5 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-08-01 09:47:10 PDT
Comment on attachment 549820 [details] [diff] [review]
With the test change

r=me.

# Inside the if's parentheses are very messy, though... I'll sort out them ASAP.
Comment 7 Marco Bonardo [::mak] 2011-08-02 03:19:26 PDT
http://hg.mozilla.org/mozilla-central/rev/908e0c628083

Note You need to log in before you can comment on or make changes to this bug.