White flash on new tab when use_document_colors=false

RESOLVED DUPLICATE of bug 558585

Status

()

RESOLVED DUPLICATE of bug 558585
7 years ago
7 years ago

People

(Reporter: mikael_eriksson, Unassigned)

Tracking

5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
When opening a new tab when browser.display.use_document_colors is false and browser.display.background_color is anything but white, the background of the new tab flashes white for a split second and then changes to whatever background_color is set to. This flash is annoying and visually jarring.

It last longer if you have a couple of javascript heavy tabs open already. On a fresh start without any pages open it's not noticable at all. It also happens when opening a new tab from the address field using alt+return.

It started happening with firefox 4, and is till there in 5. It wasn't there in firefox 3.5 or before. I'm using the version downloaded from getfirefox.com on Linux with a freshly created profile.

Comment 1

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110711 Firefox/8.0a1

The problem you have logged was fixed in Bug 558585, but it will land in the stable version of Firefox 6. You can start using the beta version of Firefox which you can download from:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/6.0b1-candidates/

Thanks for your report!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558585
You need to log in before you can comment on or make changes to this bug.