Last Comment Bug 670079 - stop caching plugin instances
: stop caching plugin instances
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Josh Aas
:
Mentors:
Depends on: 700835
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-07 23:15 PDT by Josh Aas
Modified: 2011-11-28 16:28 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (16.52 KB, patch)
2011-07-07 23:16 PDT, Josh Aas
jst: review+
Details | Diff | Review

Description Josh Aas 2011-07-07 23:15:04 PDT
I don't think we ever want to restart a plugin instance so we can stop caching them entirely and remove code that looks for an old stopped instance to re-use when instantiating.

I'm not sure we want to support NPPVpluginKeepLibraryInMemory either. Right now that marks an instance for caching, which effectively prevents its plugin from ever unloading since an instance will remain indefinitely. This is a silly way to implement it, a better way would be to just mark the plugin as do-not-unload when this is set on any instance. However, since we don't unload plugins by default anyway this isn't really an issue.
Comment 1 Josh Aas 2011-07-07 23:16:22 PDT
Created attachment 544733 [details] [diff] [review]
fix v1.0
Comment 2 Johnny Stenback (:jst, jst@mozilla.com) 2011-07-08 09:32:57 PDT
Comment on attachment 544733 [details] [diff] [review]
fix v1.0

Yeah, this never seemed like a good idea to me either. r=jst
Comment 3 Josh Aas 2011-07-08 09:40:50 PDT
pushed to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/b4725ef65601
Comment 4 Nochum Sossonko [:Natch] 2011-07-11 11:26:46 PDT
Does this fix bu 659348?
Comment 5 Nick Thomas [:nthomas] 2011-11-13 16:48:15 PST
If I'm reading 
  https://wiki.mozilla.org/RapidRelease#Merge_and_Release_Dates
correctly this fix was first in Firefox 8.
Comment 6 Steven Michaud [:smichaud] (Retired) 2011-11-13 17:10:37 PST
Yes.  And this is confirmed by the names of the 2011-07-08 and 2011-07-09 mozilla-central nightlies, which claim to be "8.0a1".

Note You need to log in before you can comment on or make changes to this bug.