url bar not showing protocol

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Tanveer Singh, Unassigned)

Tracking

7 Branch
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:7.0a2) Gecko/20110706 Firefox/7.0a2
Build ID: 20110706042005

Steps to reproduce:

Go to any side, eg www.yahoo.com



Actual results:

The address/url bar shows just www.yahoo.com, and not http://www.yahoo.com.


Expected results:

Full address should be shown, or there should be a preference setting to show full address. For example if I need to do https, earlier I would just put an 's', not I need to type https://
Older Aurora 6 branch did not have this issue.

Comment 1

6 years ago
The about:config preference to set to false is
browser.urlbar.trimURLs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 2

4 years ago
I'm not satisfied with this:
-only few people will do this change in the dangerous about:config screen
-The hidding shouldn't be set by defaut, since it's in opposition with Mozilla and free software line about people self-knowledge of basis of how things work so they can defend their liberty
You need to log in before you can comment on or make changes to this bug.