Last Comment Bug 670226 - "ASSERTION: negative length" with rtl, pre-line, :first-letter{float}
: "ASSERTION: negative length" with rtl, pre-line, :first-letter{float}
Status: RESOLVED FIXED
[qa-]
: assertion, regression, testcase
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: ---
Assigned To: Simon Montagu :smontagu
:
:
Mentors:
Depends on:
Blocks: randomclasses 665837
  Show dependency treegraph
 
Reported: 2011-07-08 12:55 PDT by Jesse Ruderman
Modified: 2011-09-22 15:51 PDT (History)
5 users (show)
smontagu: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
testcase (152 bytes, text/html)
2011-07-08 12:55 PDT, Jesse Ruderman
no flags Details
Patch (1.72 KB, patch)
2011-07-11 10:57 PDT, Simon Montagu :smontagu
roc: review+
asa: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
Tests (2.42 KB, patch)
2011-07-11 10:58 PDT, Simon Montagu :smontagu
roc: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2011-07-08 12:55:30 PDT
Created attachment 544884 [details]
testcase

###!!! ASSERTION: negative length: 'GetContentEnd() - mContentOffset >= 0', file nsTextFrame.h, line 360
Comment 1 Simon Montagu :smontagu 2011-07-11 10:57:59 PDT
Created attachment 545211 [details] [diff] [review]
Patch

This is caused by a bug that I noticed by code inspection while working on bug 668941 and was going to file as soon as I had worked out a reftest for it. It's a regression from 665837: when we break off traversing frames because the last sibling is before the newline, we shouldn't be calling ResolveParagraph.
Comment 2 Simon Montagu :smontagu 2011-07-11 10:58:30 PDT
Created attachment 545212 [details] [diff] [review]
Tests
Comment 3 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-07-11 16:52:16 PDT
Comment on attachment 545211 [details] [diff] [review]
Patch

Review of attachment 545211 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-07-11 16:52:44 PDT
Comment on attachment 545212 [details] [diff] [review]
Tests

Review of attachment 545212 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 6 Simon Montagu :smontagu 2011-07-19 04:07:19 PDT
Comment on attachment 545211 [details] [diff] [review]
Patch

This fixes a regression from bug 665837 which was checked in on Aurora, so the fix should go on Aurora too. Beta is unaffected.
Comment 8 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-09-22 15:51:58 PDT
qa- as no QA fix verification needed

Note You need to log in before you can comment on or make changes to this bug.