Final popup windows pops up blank when using mozilla!

RESOLVED FIXED in Bugzilla old

Status

()

Bugzilla
Bugzilla-General
RESOLVED FIXED
18 years ago
6 years ago

People

(Reporter: Thue Janus Kristensen, Assigned: gerv)

Tracking

unspecified
Bugzilla old
x86
Linux

Details

(URL)

(Reporter)

Description

18 years ago
Entering a bug report with mozilla doesn't work. When I click on the "Open
bugzilla entry form" all I get is a blank popup window. (well, actually I get a
window with my homepage, but that is a known mozilla bug).
This bug is 100% reproducible.

Comment 1

18 years ago
-> Gerv
Assignee: tara → gervase.markham
(Reporter)

Comment 2

18 years ago
Umm, I should just make it crystal clear that the problem is with the bug
helper, not bugzilla itself...
I _think_ this was due to a JS error I introduced during an update, which I have 
since fixed. Reporter - could you try this again, please?

Gerv
(Reporter)

Comment 4

18 years ago
Nope, still doesn't work.
Can I have a Build ID, please? Also, I need to know what the Javascript console 
says (i.e. if there are any errors). Can't remember where it is offhand - search 
the menus :-) 

Gerv
(Reporter)

Comment 6

18 years ago
it is in tasks->tools.

My build is 2001012506

You seriosly need to make the javascript console cut-pastable! Here is a copy by
hand:
-----------
<1>
Error:
Source File: chrome://global/content/scrollbarBindings.xml#scrollbar.initScrollbar()
Line: 2					Column: 0

<2>
Error: uncaught exception: SCrollbars in this skin are not properly supporteg
mac smart-scrolling prefs!
Line: 0			COlumn: 0

<3>
Same as <1>

<4>
Same as <2>

<5>
Error:
Source File: http://www.mozilla.org/quality/help/bugreport.js
Line: 90			Column: 0

<6>
Error: uncaught exception:[Exception..."Access to property denied" cpde:
       "1010" nsresult: "0x805303f2
       (NS_ERROR_DOM_PROP_ACCESS_DENIED)" location:
       "http://www.mozilla.org/quality/help/bugreport.js Line: 90"]
Source File:
Line: 0					Column: 0
(Reporter)

Comment 7

18 years ago
I just compiled the very latest and greatest version of the source code. Still
doesn't work.
Worksforme on Win95, 20010129 downloaded nightly. I will try with Linux soon.

Gerv

Comment 9

18 years ago
See also bug 67215.
Mozilla 20010202 worksforme on Linux 2.2.13, with KDE. <shrug> I have no idea
where to go from here.

Those JS errors don't look like they are related to Bugzilla Helper. Could you
make sure you press the Clear button on the JS console just before you attempt
to use the Helper, and see if you still get them?

Gerv
(Reporter)

Comment 11

18 years ago
Pressing the clear button before gives the same errors.

I just had an "accident" with my debian unstable, so I reinstalled (debian
testing this time). The error is still there.
OK, what's happening here is that the Javascript Security Manager is not letting 
the script write to the new window it's created. I wonder why:
a) It works on other platforms
b) It works for me on Linux but not for you.

We really need the man who owns this code to come and explain things to us. Step 
forward, norris@netscape.com :-)

Gerv
(Reporter)

Comment 13

18 years ago
Just an idea - it might be a consequence of the new window is not empty bug. Try
setting your homepage to fx
http://hjem.get2net.dk/thue_janus_kristensen/links.html , and set browser start
to the homepage and see if you get the bug.

Comment 14

18 years ago
Possible dup of bug 66034, "Content in Mozilla disappears seemingly at random", 
which is marked as "critical for 0.8".
(Reporter)

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

17 years ago
I can't reproduce this bug any more; marking fixed.
Component: Bugzilla → Bugzilla Helper
Webtools/Bugzilla Helper is being retired.
Component: Bugzilla Helper → Bugzilla-General
Product: Webtools → Bugzilla
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.