Group all compartments together in about:memory

RESOLVED DUPLICATE of bug 687724

Status

()

defect
RESOLVED DUPLICATE of bug 687724
8 years ago
7 years ago

People

(Reporter: justin.lebar+bug, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

There are currently a few reporters directly under js which are easy to miss because they're stuck between the long list of compartments:

  gc-heap-chunk-unused
  gc-heap-chunk-admin
  stack

Maybe this would be better if we grouped all the compartments together under js/compartments.
My only concern here is that this will put all of those at the end, pretty much all the time.  Maybe that's ok.  The current setup is kind of annoying too.
Grouping them under js/compartments would be the way to do it, I don't want to modify the existing "order sub-trees by size" approach.

But I don't think it's necessary.  An extra level of indentation for compartments will be annoying.  I don't expect the three you name will be significantly easier to find if you don't already know about them.
(In reply to comment #2)
> Grouping them under js/compartments would be the way to do it, I don't want
> to modify the existing "order sub-trees by size" approach.

Agreed.

> But I don't think it's necessary.  An extra level of indentation for
> compartments will be annoying.  I don't expect the three you name will be
> significantly easier to find if you don't already know about them.

It's definitely a tradeoff.  I have bigger fish to fry about about:memory, so if you don't think it's worth it, let's not do it.  :)
Bug 702300 is a better way to do this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 702300
Oh, this is about overlooking the non-compartment entries.  Still, per-tab reporting (bug 687724) will render this moot.
Duplicate of bug: 687724
You need to log in before you can comment on or make changes to this bug.