Notify user of successfully installed web app

RESOLVED WONTFIX

Status

Fennec Graveyard
General
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: mfinkle)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

6 years ago
After installing a web app via the site identity panel, the user should be notified if it was successfully installed or not, either by some fancy animation or simply via a toaster notification: "<shorthand site name> web application successfully installed."
I suppose a toaster isn't too bad.

Madhava - thoughts?
(Assignee)

Updated

6 years ago
Assignee: nobody → mark.finkle
(Reporter)

Updated

6 years ago
Duplicate of this bug: 673906
I don't think a "installed!" notification goes far enough.

Unless the user has read the Fennec user manual, they'll never know where their "app" went unless the notification explicitly describes how to find it and add it.

If this is an "app", then it should install like one: in Applications. That would meet the user's expectation from a menu item labeled "Install as app".

Otherwise, we should change the label in the UI to "Create shortcut". This would be consistent with this feature's behavior and Android's terminology for this feature.

Even that wouldn't meet a criteria of Just Works, since it's actually just creating the ability to add a shortcut, not actually adding it anywhere, which could be frustrating to people who don't go digging around through submenus' submenus. It should also add the shortcut to an available homescreen. (Note: Honeycomb adds newly installed apps to the homescreen automatically.)
Er, sorry for hijacking this bug. I'll file a separate one if you want.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.