Last Comment Bug 670794 - GCC 4.6 build warning: "jsemit.cpp:4112:10: warning: variable ‘forInLet’ set but not used [-Wunused-but-set-variable]"
: GCC 4.6 build warning: "jsemit.cpp:4112:10: warning: variable ‘forInLet’ set ...
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
Depends on:
Blocks: buildwarning 381843
  Show dependency treegraph
 
Reported: 2011-07-11 17:18 PDT by Daniel Holbert [:dholbert]
Modified: 2011-07-12 04:01 PDT (History)
1 user (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.57 KB, patch)
2011-07-11 17:22 PDT, Daniel Holbert [:dholbert]
jwalden+bmo: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-07-11 17:18:45 PDT
GCC 4.6 build warning:
{
jsemit.cpp:4112:10: warning: variable ‘forInLet’ set but not used [-Wunused-but-set-variable]
}

Looks like bug 381843 ( http://hg.mozilla.org/mozilla-central/rev/d8b2189bb4ba ) removed the last usages of this variable, & the variable itself can just go away.
Comment 1 Daniel Holbert [:dholbert] 2011-07-11 17:22:13 PDT
Created attachment 545290 [details] [diff] [review]
fix
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2011-07-11 17:36:01 PDT
Comment on attachment 545290 [details] [diff] [review]
fix

Yoink.
Comment 3 Daniel Holbert [:dholbert] 2011-07-11 19:29:00 PDT
I landed this on tracemonkey...
   http://hg.mozilla.org/tracemonkey/rev/ab57a16c66fc
...but Waldo told me that JS team is currently landing patches on mozilla-inbound instead of on tracemonkey, and that I should re-land there instead.

I'll do that in the next day or so, once mozilla-inbound is less orange. :)
Comment 4 Daniel Holbert [:dholbert] 2011-07-12 00:17:48 PDT
Re-landed on mozilla-inbound, per comment 3:
 http://hg.mozilla.org/integration/mozilla-inbound/rev/a5a4c874ace4

(At Waldo's direction, I'm ignoring the already-landed tracemonkey cset - not backing out there -- since that branch isn't being actively merged to m-c right now.)
Comment 5 Mounir Lamouri (:mounir) 2011-07-12 04:01:01 PDT
Merged:
http://hg.mozilla.org/mozilla-central/rev/a5a4c874ace4

Note You need to log in before you can comment on or make changes to this bug.