The default bug view has changed. See this FAQ.

Backspace & Delete don't work on first or last character in a selection in contenteditable inline elements (such as spans) nested in another inline element

VERIFIED FIXED in mozilla8

Status

()

Core
Editor
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Aaron Kaluszka, Assigned: kaze)

Tracking

({reproducible, testcase})

Other Branch
mozilla8
x86
Windows 7
reproducible, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Step 1: Select text in a contenteditable inline (which is nested in another inline) such that either the first or last character is included in the selection.
Step 2: Press backspace or delete.

Expected Results: All selected text is deleted.

Actual Results:
- If the selection included the first character, only the last character in the selection is deleted and the text is deselected.
- If the selection included the last character, nothing is deleted and the text is deselected.
- If the selection included all characters, nothing is deleted and the text remains selected.
(Reporter)

Updated

6 years ago
See Also: → bug 439808
(Reporter)

Updated

6 years ago
Blocks: 237964
Keywords: reproducible, testcase
(Reporter)

Updated

6 years ago
Summary: Backspace & Delete doesn't work on first or last character in a selection in contenteditable inline elements (such as spans) nested in another inline element → Backspace & Delete don't work on first or last character in a selection in contenteditable inline elements (such as spans) nested in another inline element

Updated

6 years ago
Assignee: nobody → kaze
(Assignee)

Comment 1

6 years ago
Bug confirmed on Aurora (Fx 7.0a2) but works for me on Nightly (Fx 0.8a1). I couldn’t find the patch that solved this issue.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla8
Version: Trunk → Other Branch

Comment 2

6 years ago
Fixed by Bug 439808
(Reporter)

Comment 3

6 years ago
This bug was filed because Bug 439808 did not fix the full problem, but I can confirm it works now.
Status: RESOLVED → VERIFIED

Comment 4

6 years ago
I checkd cached m-i hourly, and confirmed this fixed by Bug 439808

Comment 5

6 years ago
Please ignore comment #2 and comment #4, I misread str.


Fixed range(m-c)
Fails:
http://hg.mozilla.org/mozilla-central/rev/504a1a927d39
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110725 Firefox/8.0a1 ID:20110725111747
Works:
http://hg.mozilla.org/mozilla-central/rev/982a5835fba1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110726 Firefox/8.0a1 ID:20110726025330


Fixed range(m-i)
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f8768a3e3a9f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110725 Firefox/8.0a1 ID:20110725115531
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/167f6642efd4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110725 Firefox/8.0a1 ID:20110725141505
Pushlog
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f8768a3e3a9f&tochange=167f6642efd4

Fixed by:
167f6642efd4	Fabien Cazenave — Bug 688599 - do not expand selection for deletion outside of the active editing host; r=ehsan When a selection in an inline element is to be deleted, it is first expanded to the parent block in order not to leave any empty inline element. This patch ensures that the selection cannot be expanded outside of the contentEditable element (active editing host).
(Assignee)

Comment 6

6 years ago
That’s bug 668599 then, thanks for finding out!
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.