Last Comment Bug 670857 - Various hudservice tests have deliberate uncaught JS exceptions that will cause a test failure in the future
: Various hudservice tests have deliberate uncaught JS exceptions that will cau...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Cameron McCormack (:heycam)
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on: 670817
Blocks: 702050 652494 703176
  Show dependency treegraph
 
Reported: 2011-07-11 23:31 PDT by Cameron McCormack (:heycam)
Modified: 2012-02-01 14:00 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make web console tests expect particular uncaught exceptions. (10.38 KB, patch)
2011-11-17 02:34 PST, Cameron McCormack (:heycam)
mihai.sucan: review+
Details | Diff | Splinter Review

Description User image Cameron McCormack (:heycam) 2011-07-11 23:31:31 PDT
Once bug 652494 is fixed, the deliberate uncaught JS exceptions from various hudservice tests will cause test failures.  We'll need to be able to indicate that these uncaught exceptions are expected, if they cannot be removed without affecting the point of the tests.  Bug 670817 might introduce a SimpleTest.expectUncaughtException() which we could use for this.

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_580030_errors_after_page_reload.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fooBazBaz is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-error.html:15
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_582201_duplicate_errors.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fooDuplicateError1 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-duplicate-error.html:16
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_582201_duplicate_errors.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fooDuplicateError1 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-duplicate-error.html:16
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_597136_external_script_errors.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: bogus is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-597136-external-script-errors.js:12
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_597756_reopen_closed_tab.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fooBug597756_error is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-597756-reopen-closed-tab.html:14
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_597756_reopen_closed_tab.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fooBug597756_error is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-597756-reopen-closed-tab.html:14
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_597756_reopen_closed_tab.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fooBug597756_error is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-597756-reopen-closed-tab.html:14
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_597756_reopen_closed_tab.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fooBug597756_error is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-597756-reopen-closed-tab.html:14
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_601177_log_levels.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: window.foobarBug601177exception is not a function at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-601177-log-levels.js:8
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_618078_network_exceptions.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: bug618078exception is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-618078-network-exceptions.html:13
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: bar is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:14
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar0 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar1 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar2 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar3 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar4 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar5 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar6 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar7 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar8 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar9 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_644419_log_limits.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fubar10 is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-bug-644419-log-limits.html:0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_network_panel.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: uncaught exception: [object StopIteration] at :0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_view_source.js | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: fooBazBaz is not defined at http://example.com/browser/toolkit/components/console/hudservice/tests/browser/test-error.html:15
Comment 1 User image Mihai Sucan [:msucan] 2011-07-29 08:37:36 PDT
Thank you for your report.

Indeed, we will have to use the new mechanism for indicating that the uncaught exceptions are expected.

Bug 652494 is a welcome improvement to mochitests. Is there a timeline for landing 652494? For when we'll have to complete our mochitest updates.
Comment 2 User image Rob Campbell [:rc] (:robcee) 2011-07-29 08:42:44 PDT
mihai, do you want to take this?
Comment 3 User image Mihai Sucan [:msucan] 2011-07-29 08:46:50 PDT
Sure, I can take it.
Comment 4 User image Cameron McCormack (:heycam) 2011-07-29 23:55:33 PDT
I guess bug 652494 will land as soon as the dependent bugs are fixed. ;)  I'm not actively working on the dependent bugs, but I may pick them up as time permits.  The actual patch for bug 652494 will be quite small.
Comment 5 User image Cameron McCormack (:heycam) 2011-11-15 18:51:03 PST
Mihai, are you working on this at the moment?  If not, I'm happy to take it.
Comment 6 User image Mihai Sucan [:msucan] 2011-11-16 03:02:16 PST
(In reply to Cameron McCormack (:heycam) from comment #5)
> Mihai, are you working on this at the moment?  If not, I'm happy to take it.

I am not working on this, at the moment. I would very much appreciate your help with taking this!

Thank you!
Comment 7 User image Cameron McCormack (:heycam) 2011-11-16 03:03:10 PST
No problem!
Comment 8 User image Cameron McCormack (:heycam) 2011-11-17 02:34:51 PST
Created attachment 575128 [details] [diff] [review]
Make web console tests expect particular uncaught exceptions.

Add expectUncaughtException() in appropriate places.
browser_webconsole_network_panel.js needed an actual fix for an unintended
uncaught exception.
Comment 9 User image Mihai Sucan [:msucan] 2011-11-17 09:18:40 PST
Comment on attachment 575128 [details] [diff] [review]
Make web console tests expect particular uncaught exceptions.

Review of attachment 575128 [details] [diff] [review]:
-----------------------------------------------------------------

Patch looks good. Thank you very much Cameron!
Comment 10 User image Cameron McCormack (:heycam) 2011-11-17 13:20:57 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/be842b38277f
Comment 11 User image Cameron McCormack (:heycam) 2011-11-17 14:51:17 PST
Backed out: https://hg.mozilla.org/integration/mozilla-inbound/rev/1b8f7b176406
Comment 12 User image Cameron McCormack (:heycam) 2011-11-17 14:57:56 PST
Will need to land this at the same time as bug 703176.
Comment 13 User image Cameron McCormack (:heycam) 2011-12-01 15:19:32 PST
https://hg.mozilla.org/mozilla-central/rev/de720961a78d
Comment 14 User image Cameron McCormack (:heycam) 2011-12-01 18:23:16 PST
Backed out: https://hg.mozilla.org/mozilla-central/rev/c101c5f8c928
Comment 15 User image Cameron McCormack (:heycam) 2011-12-02 04:28:22 PST
Trying again: https://hg.mozilla.org/integration/mozilla-inbound/rev/90cb5809e7f0
Comment 16 User image Ed Morley [:emorley] 2011-12-02 12:05:52 PST
https://hg.mozilla.org/mozilla-central/rev/90cb5809e7f0

Note You need to log in before you can comment on or make changes to this bug.